IDEA 4.0.3 crashes the moment I launch on XP

Worked fine for a few days, but I had a system panic and now any effort to launch IDEA quickly ends in a stack trace:

java.lang.NullPointerException
at com.intellij.diagnostic.DialogAppender.append(DialogAppender.java:4)
at org.apache.log4j.AppenderSkeleton.doAppend(AppenderSkeleton.java:221)
at org.apache.log4j.helpers.AppenderAttachableImpl.appendLoopOnAppenders(AppenderAttachableImpl.java:57)
at org.apache.log4j.Category.callAppenders(Category.java:190)
at org.apache.log4j.Category.forcedLog(Category.java:375)
at org.apache.log4j.Category.error(Category.java:306)
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:18)
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:143)
at com.intellij.ide.plugins.c.a(c.java:132)
at com.intellij.ide.plugins.c.a(c.java:208)
at com.intellij.ide.plugins.c.a(c.java:211)
at com.intellij.idea.Main.main(Main.java:19)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at com.zerog.lax.LAX.launch(DashoA8113)
at com.zerog.lax.LAX.main(DashoA8113)

It is repeatable... which means I am dead in the water. Just downloaded latest on Apr 8th (1182?). How can I clear the logjam?

tone

1 comment
Comment actions Permalink

Just guessing but I'd rename the existing install dir and re-install. If that worked, I'd use BeyondCompare to compare the two sets of folders, both to compare the differences and to copy any saved settings across (checking it still works after each copy!)

0

Please sign in to leave a comment.