Q: FileTemplates in CVS


we have our FileTemplates checked into the cvs repository. Problem is, that CVS tags get already expanded. So when one creates a new class file, it looks like this:

while it should look like this: (see the footer comment)

Anybody any idea for a solution?


1 comment
Comment actions Permalink

You should add the FileTemplates files to CVS without keyword substitution. It means if you use command line cvs client you should add it with flag "-ko".

From other side you can leave it as is - it'll be replaced with the right values when you'll commit the new class file, generated from this FileTemplate.

Hope this helps.




Please sign in to leave a comment.