Question on setting code indentation and format

Hi Everyone:
I'm currently trying out several Java ide's in order to see which I want to
purchase. I have a question regarding setting Idea's code
formatting/indentation.
I have spent a couple of hours trying to see if I can get it to indent as
other programs do. Each line is all the way to the left in the editor box.
I would like it to look like the following (which is from a different
program):


Here is how it looks on my computer in Idea:


Here are my setting in Idea under code style: Please let me know what is set
wrong... or if it is possible to sent it to indent with idea.








Attachment(s):
scl1.PNG
scl2.PNG
scl3.PNG
Indented.jpg
2 comments
Comment actions Permalink

I doubt that your problem has anything to do with Idea's code style setting. It seems that you have setup the project modules/paths incorrectly. See the read icon in the tab for "Exercise1b.java". It basically means that the file is not in any source path.
Have a look at at your project settings, "Paths", "Modules" and in the rightmost tree mark your folder as "source".

0
Comment actions Permalink

Hi Stephen:

Thanks for the info. I thought when I had set up the project (s) I had done
so correctly. I think I had clicked to create a new .java source file on
the folder above the .src level. Idea seems to work correctly when I create
a new source file the the .src section. The other programs I looked at seem
to automatically create .java files in the "right" place, but I guess Idea
gives more options. Thanks again for the help its working correctly now : )
Matt

"Stephen Kelvin" <mail@gremlin.info> wrote in message
news:21663485.1080717652564.JavaMail.itn@is.intellij.net...

I doubt that your problem has anything to do with Idea's code style

setting. It seems that you have setup the project modules/paths incorrectly.
See the read icon in the tab for "Exercise1b.java". It basically means that
the file is not in any source path.

Have a look at at your project settings, "Paths", "Modules" and in the

rightmost tree mark your folder as "source".


0

Please sign in to leave a comment.