Line Feed characters problem with CVS & IntelliJ 4.0

I'm developing in Windows and deploying to a UNIX environment. The problem is that I'm getting Windows line feed characters (^M) on some files when checking out modules from CVS using IntelliJ 4.0 CVS integration tool.

With WinCVS there is command line parameter, --lf, that will use the Unix line feed character when checking out modules. With IntelliJ 3.0.5, I was able to specify this parameter in the global options of the CVS Support-> Advanced tab. Using this in combination with the Line Separator option in IDE Settings, I was able to eliminate any problems with the Windows ^M.

IntelliJ 4.0 does have the Line Separator option within Global Code Style IDE Settings, which I've made sure is set to 'Unix \n'. However, there is no option in the CVS settings that let you specify something about the Line Feed characters.

Anyone experience this problem with 4.0 or have a workaround to get this going?

Thanks.

1 comment

I'm having a related issue: I want to use the cool new Idea 4 CVS, but also use cmdline CVS from time to time. I am on WinXP.

I'm also using CVS over SSH, with pubkey auth. I got things working within IDEA by letting IDEA checkout my project fresh. This produced CVSROOT starting with :ext: in all my CVS/Root files.

I can get cmdline CVS to work using this same CVSROOT, but even for a non-modified project, "cvs diff" from cmdline produces huge diffs. I suspect this is a line-ending issue.

What version of any WinXP CVS cmdline client works with IDEA best? I've tried a recent CVSNT, an older WinCVS1.3, and the cygwin version, all to no avail. (cygwin version doesn't work at all, giving me some malformed "/CVSROOT.... No such file or directory" error.)


Thanks!

0

Please sign in to leave a comment.