combination of keys in PhpStorm with non-English keyboard layouts

Salutations

I suppose my problem has more relations to Storm rather than to OS.
I am using PhpStorm (but the same problem appeared in IDEA) on OS Ubuntu.

Yesterday I had two upgrades
- PhpStorm to v7
- and Ubuntu to v13.10 (x64)

Today I've noticed that combination of keys such as
Ctrl+N, Ctrl+T, <Ctrl/Alt/Shift>+<some_English_key> works only when keyboard layout is switched to "English".

When I use Russian/Ukrainian layouts I need to switch keyboard layout to English before using such combinations and then switch back to continue work (text typing, comments, reviews etc)
This is terribly uncomfortably.

Does someone know how to solve this?

thanks in advance

3 comments

seems this is not a Storm problem


this issue related to all applications written in Java
0

Hi there,

Just a wild guess (since I'm not really a Linux user) -- what is the primary language/layout you have there? Try setting it to English if it's another one.

0

I've found solution...very stupid, but works well for me
I just escaped from Ubuntu to Mint, and all workd fine now (I had to do this year or two ago)

0

Please sign in to leave a comment.