PhpStorm 7 and Live templates

After upgrade to PhpStorm 7 I noticed that livetemplates suggestions have priority in suggestion list lower than constructions

For example, I have live template called "foreach"

liveTemplate.jpg


Before update: I type "foreach" (suggestion menu opens) press [Tab] - livetemplate applied.

After update: I type "foreach"  (suggestion menu opens) press [Tab] - suggestions menu closes (!) and live template wasn't applied, press [Tab] again - livetemplate applied.

What I see now - my live template for "foreach" is on second place in suggestion list and suggestion for construction "foreach" on the top, so casically now I have to press [Tab] twice! to apply live template, which is pritty inconvinient.

foreach.jpg
Is there anything I can do about it?

Just in case, screenshot of my settings.

settings.jpg

Checkbox "Sort lookup items lexicographically" doesn't help.

5 comments

I have the same exact problem with Emmet.

autocomplete.gif

The font-face autocompletion has a highest priority than font-family. But it's kinda a problem since i typed the "ff" : Emmet's shorthand code to get font-family.
I would be glad to know if there is a specific setting to avoid that.

Thanks in advance.

0

Hello!

this is how the http://youtrack.jetbrains.com/issue/WEB-9384 was fixed: now indeed templates have lower priority than code constructions

0

But it is ridiculous and inconvinient =) Is there any way to get my one-tab live templates back?

0

Well, ok for the Live templates.
But since there is the exact same problem with Emmet. Will it be fixed to ? Or do i need to create an issue about it ?

0

Please sign in to leave a comment.