WebStorm 7 stuck performing code analysis

In certain files I am working with in my most recent project, it shows an eyeball in the upper right where it normally shows color (green, yellow, red).  if I mouse over it, I get a tooltip message stating "Performing code analysis" and "3 warnings so far."  It is stuck like this for days, if I restart, if I reinstall WebStorm if I file -> invalidate caches/restart, if I rm -rf .idea in the project directory, etc.

I tried commenting out the whole file and I get the green square.  I then commented in a function at a time until it got stuck.  This is the function in question:

        updateQuantity : function (id, newQuantity) {
            var items = batchItems;

            if (!items[id]) {
                // should never happen
                throw new Error('Item ' + id + ' not in batch');
            }
            items[id]['@Qty'] = newQuantity;
        },


My guess is the @ in the string.  Unfortunately, the JSON I'm working with is not in my control and almost all members start with @.

However, this function later in the file also causes the problem if the above function is commented out (// at beginning of each line):

        getItemCount : function () {
            return count;
        },


I went into settings and disabled every plugin and of course it worked.  Enabling only the javascript support plugin was enough to cause the error condition.  I use no additional plugins other than the ones that came with WebStorm installation.

Attached is my idea.log file



Attachment(s):
idea.log.zip
3 comments
Comment actions Permalink

Thank you.

I downloaded the 7.0.1 RC version and I can report it does appear fixed.

However, when I did check for updates in 7.0, it showed me the 7.0.1 RC version with an "update and relaunch" button.  I clicked the button, it appeared to download, it restarted, but was still running the 7.0 version.  I ended up downloading the installation file from the WWW site and doing the install manually.

Mac OSX Mountain Lion.

0

Please sign in to leave a comment.