IntelliJ debugger causes exception: Netscape security model is no longer supported.

I'm using some thirdparty software within my code and it has problems running via IntelliJ, it uses an older security package. I'm using IDEA 4.0 and have configured it to use java 1.4.1_02.

The software runs fine on the command line using the same 1.4.1_02 java.

Is there an option to make the IntelliJ debugger use a specific security package or something like that to work around this?

See detailed stack below:

Netscape security model is no longer supported.
Please migrate to the Java 2 security model instead.
java.lang.NoSuchMethodError: netscape.security.PrivilegeManager.getMyPrincipals()[Lnetscape/security/Principal;
at xjava.security.IJCE_SecuritySupport.registerTargets(IJCE_SecuritySupport.java:159)
at xjava.security.IJCE_SecuritySupport.<clinit>(IJCE_SecuritySupport.java:138)
at xjava.security.IJCE.findTarget(IJCE.java:501)
at xjava.security.IJCE.getProviderInternal(IJCE.java:669)
at xjava.security.IJCE.getClassCandidate(IJCE.java:449)
at xjava.security.IJCE.getImplementationClass(IJCE.java:413)
at xjava.security.IJCE.getImplementation(IJCE.java:370)
at xjava.security.Cipher.getInstance(Cipher.java:488)
at xjava.security.Cipher.getInstance(Cipher.java:455)

Please sign in to leave a comment.