Warnings on new NodeJS project

I just downloaded WebStorm7, created a new NodeJS project and set the NodeJS settings and WebStorm is giving me warnings all over the place.

I have not written any code! This is all the WebStorm template code.

With all the warnings, the app runs fine, so it seems like WebStorm can't figure something out.

The first being, in the app.js file, there are numerous warnings about number of parameters being incorrect and methods not found.

Below is a pick the app.js file, the external dependencies and the NodeJS settings.

How do I get WebStorm the info it needs to stop giving me all these warnings.?

app.js:
warnings.PNG
External Dependencies:
external dependencies.PNG
NodeJS Settings:
settings.PNG

4 comments

I just tried the same thing. Downloaded the demo to see if I would like using Webstorm for NodeJS devleopment.  First I tried to create a Node.JS Boilerplate project. When running the bat file to install the project it seems to throw a bunch of errors then exits. OK well that has a lot of extra stuff I won't need anyway so I tried the Node.JS Express App project which is more in line with what I'd need. That one seems to work and run without any changes, but I have the same problem as the OP. The base project is riddled with "Unresolved function or method" and "Invalid number of parameter" warnings all over the place. I didn't change anything or write one line of code.

Is this going to be fixed and soon? The app does run, but it makes a hard case to want to pay for the IDE when it doesn't work right out of the box. I don't really want to be writing code in an IDE that is going to be riddled with warnings all over the place. How will I know which ones are valid?  Is the Create New Project functionality the problem?

I like some of what I've seen so far, but I'd like to know what the chances are of this being fixed before the 30 day trial runs out.

Thanks.

0

Its definitely frustrating, but I ended up turning off some of the JavaScript inspections. It does not seem to hurt the day to day coding process and gets rid of the warnings.
From the settings, select Inspections, the JavaScript / General and uncheck "Signature Mismatch Problem" and "Unresolved JavaScript Function".

0

Considering how "dynamic" JavaScript can be, I can understand the difficulty in getting this to work. In the mean time I have turned of the inspection settings related to the problem.

From the settings, select Inspections, the JavaScript / General and uncheck "Signature Mismatch Problem" and "Unresolved JavaScript Function".

0

Please sign in to leave a comment.