CVS Problems after Upgrade to 4.0

RE: IDEA 4.0 Build 1162, Mac OS X 10.3.2/Java 1.4.2_03

All,

I just upgraded to 4.0 from 3.x, and I am having problems with CVS not working. When I try to commit or diff a file, I get the following message: "Invalid cvs root: absent". CVS commits work fine from the comand line, and they worked fine in 3.x as the same user with the same project as I am using now. I see in the help that there is a now a CVS roots panel , but since my project is already checked into the CVS repository, it appears that I shouldn't need to configure my CVS roots. Regardless, I did add a CVS root for the server that handles my project, but I still get the same error. Interestingly, the CVS File View panel shows what I believe is all the correct information about which files are modified, what version they are, etc.

I use CVS with rsh = ssh, and I have authorized_keys2 set up so that I don't have to enter a password when doing cvs operations. The CVS_RSH setting is configured in ~/.MacOSX/environment.plist. Again, all of this worked in 3.x. If anyone can tell me what I need to do in 4.0 to get this working, I would very much appreciate it.

Regards,
Paul

3 comments

All,

After speaking with IntelliJ Support, I learned the following:

"3.0 uses command line cvs so it supports all what cvs client supports.
4.0 is implementing its own cvs client and there is some part of non
supported functionality.
At the moment 4.0 is supporting pserver, internal implementation of ssh1
and ext connection (using private password key file only)."

So, I was able to resolve my problems by checking out my project from the repository again after setting my CVSROOT=:ext:myUserName@mycvsserver.com:/opt/cvsroot

So far, this seems to have done the trick!

Regards,
Paul

0

Hi Paul,

This sounds like your connecting using the ext option - is that rsh or ssh. Which ssh are you using - what entries do you have in the ext protocol config section, that is, ssh location, password file and additional params?

Thanks,
Chris

0

Hi,

Ok - I now have this working - I had ssh keys setup previously, but the bit that was a problem was that you always need to specify the user id with IDEA now... it seems to ignore the fact that my local PC login is ok to use...

I am using the cygwin ssh command line - the path to private key is blank and I have "-C" compression as a command line param.

Chris

0

Please sign in to leave a comment.