JDK 1.4 vs 1.5 + IDEA + Tomcat 5.0.18

In JDK 1.4_02 everythink goes ok, but when i switch
to JDK 1.5beta and i try to debug webservice with tomcat 5.0.18 i've got errors:

D:\serwer\java\j2se15\bin\javaw.exe -classic -Djava.endorsed.dirs=D:\serwer\java\tomcat50\common\endorsed -Dcatalina.base=C:\Programy\utils\intelijidea4\system\tomcat_ksantypa_d1f7fe98 -Dcatalina.home=D:\serwer\java\tomcat50 -Djava.io.tmpdir=D:\serwer\java\tomcat50\temp -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=GHOST:4178,suspend=y,server=n -classpath "D:\serwer\java\j2se15\lib\tools.jar;D:\serwer\java\tomcat50\bin\bootstrap.jar" org.apache.catalina.startup.Bootstrap start

here is the error:

FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=JVMTI_ERROR_INTERNAL(113)
Warning: classic VM not supported; client VM will be used
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_LOAD(509) ["debugInit.c",L476]
JDWP exit error JVMTI_ERROR_INTERNAL(113): No transports initializedVM initialization failed for: D:\serwer\java\j2se15\bin\javaw.exe -classic -Djava.endorsed.dirs=D:\serwer\java\tomcat50\common\endorsed -Dcatalina.base=C:\Programy\utils\intelijidea4\system\tomcat_ksantypa_d1f7fe98 -Dcatalina.home=D:\serwer\java\tomcat50 -Djava.io.tmpdir=D:\serwer\java\tomcat50\temp -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=GHOST:4178,suspend=y,server=n -classpath D:\serwer\java\j2se15\lib\tools.jar;D:\serwer\java\tomcat50\bin\bootstrap.jar org.apache.catalina.startup.Bootstrap start

So it's look like internal JDK error

Comment actions Permalink

i use IDEA 4.0 #1162 at Windows XP,

any workarounds? or should i ask at sun jdks forums?

Comment actions Permalink

Sorry, but JDK 1.5 still not released. And JetBrains still not anounced that IDEA 4.0 support JDK 1.5. Otherwize, JetBrains said about "not supporting" of Tiger...

So, i think, if you read forums a litle, you can find more issues of JDK 1.5.



Please sign in to leave a comment.