changing url to localhost

i installed phpstorm and write a html program but each time run it this address "file:///C:/Users/Saeedeh/PhpstormProjects/it/it.html" is shown. how can i change it to localhost.

10 comments
Comment actions Permalink

Hi there,

You have to configure and mark as default a deployment entry at "Settings | Deployment"

P.S.
What PhpStorm version do you use?

0
Comment actions Permalink

thanks it works. url changed to local host but when i run program error messege shown.
"Network Access Message: The page cannot be displayed"
phpstorm version 6.0.3

0
Comment actions Permalink

Don't know ...

Do you have any local web server installed (for example: Apache/IIS)? Is it configured correctly?

0
Comment actions Permalink

i install xampp and all of its services are on.
i attach picture of phpastorm cofiguration



Attachment(s):
4.png
3.png
2.png
1.png
0
Comment actions Permalink

i check this page, my configuration is correct, but when i run html file error dispaly in browser

0
Comment actions Permalink

That message means that browser is having problem with contacting your web server (most likely, since it's network related).

1) What URL is requested?
2) Does it work if you type URL manually in the browser?
3) Please try 127.0.0.1 instead of localhost -- will it help?

0
Comment actions Permalink

it solved.
but i manually copy html file to local folder htdocs. it dident copy automatically to htdocs.

0
Comment actions Permalink
it dident copy automatically to htdocs.

What do you have at "Settings | Deployment | Options --> Upload changed files automatically to the default server" ? Quite likely you have fortgot to enable it (value should be other than "Never")

0
Comment actions Permalink

thanks a lot.
every thing is ok.

0

Please sign in to leave a comment.