PhpStorm 6: External file changes sync may be slow

Is there anyway to remove this unnecessary warning message that appears every time I start PhpStorm 6? Perhaps it should only be displayed if a slow network is detected, but our network is a Gigabit one and has never been slow, so there's no need for it to pop up.

11 comments

Slow sync is a consequence, that message also gives out a reason. Is it because of your project is on a network disk?

0

Heads up I also receive this warning when in Linux accessing files on a locally mounted Windows NTFS (fuseblk) drive. 6.0 and previous versions. Doesn't really bother me.

0

I'm not overly affected by it, just seems unnecessary to say there's a problem when there isn't. Versions prior to 6 didn't do this. I'm using local drives mapped as network shares too.

0

Network disk performance is rather unpredictable thing.

So, right now you can tune the notification (or even disable it completely) in Settings | Notifications | File Watcher Messages. But if this behavior reaaly bothers/annoys you feel free to file an issue and we'll try to find something smarter.

0

In my case PHPStorm complains, that I'm using network drive, but I'm not.

How should I report this bug - what information would help your devs?

0

Exact version of PhpStorm you use, and /etc/mtab line for a volume your project is located on.

0

Same problem here. My files are not under a network folder and the message apper at random.

0

This is becoming increasingly annoying. Is there anything that can be done about this ?

0

I work on the latest version 6.03, and it is Winodws, not Linux.

Ok, anyway I got the idea.

0

Guys,

- if your project files are all on a local disk: please try PhpStorm 7 EAP, and if you'll see the warning again please file an issue and attach the log file (Help | Show Log).
- if some files are on a mounted disk: go to Settings | Notifications | File Watcher Messages and tune it.

0

My project is on my local machine but I still received this warning message. I know why, I have XAMPP-VM web server on my local and it likes my project is on network. It doesn't bother me, just mute my pc for a min when I open phpStorm :), 

0

Please sign in to leave a comment.