Webstorm javascript debugger stops in random lines and ignores my breakpoints


I've downloaded lastest Webstorm for OSX and when I run simple static app with 18k line vendor script attached (angular.js) it stops in some random lines and ignores breakpoints I've set. Few times it randomly worked as intended but for the most runs it just ignores breakpoints.

I'm debugging it with latest Chrome version 29.0.1547.76 with JetBrains IDE Support plugin installed.

I've noticed that it works for shorter scripts - it correctly stops on breakpoints.

I've attached some shots, two with random unwanted stops and one with correct stop on my breakpoint in short script. (Screenshots done during same debug run)

My main issue is that breakpoints in that long script are ignored, I don't really care if it stops in some unwanted lines as long as all breakpoints work.

Any ideas how to fix this?

Screen Shot 2013-09-23 at 9.47.33 AM.png
Screen Shot 2013-09-23 at 9.43.53 AM.png
Screen Shot 2013-09-23 at 9.43.46 AM.png

Please sign in to leave a comment.