Can't get Live Edit to work in WebStorm

I am trying to get Live Edit to work but it looks like I am unable. When I first installed WebStorm Live Edit worked nearly out of the box. Next time I opened it up it didn't. I followed the the wiki steps (installed the Chrome Extension and enabled View->Live Edit) but there is no highlighting nor real time refreshing (I have to press F5 manually to see the changes). The browser plugin says "Conected to WebStorm 6" and if clicked sends me the WS window. Chrome displays the "Jetbrains IDE is debugging this tab" message whenever a file is changed, however Live Edit does not work. Plugin console reports many "unable to load resource" errors and links an html file with the WS build numbers. I have tried both with a local web server (Apache) and without it. It seems like the file:// approach is closer to working since WS reports to be unable to upload the files to the Apache directory (I guess that is because the directory permissions, but that's not a problem since I use lsyncd to upload my files). I have also tried changing the port of the plugin (plugin is unable to connect to connect to WS) and reinstalling WS.

I am running Ubuntu 12.10 and latest WebStorm.

Thanks in advance.

7 comments

please can you provide your extension console contents? Also, what is your WebStorm build number?

0

I've attached a screenshot of the console. Now it does not link to a html but to a file that can't be opened. Build number is 129.664. Hope that helps. Thanks!

screenshot.png

0

ok... Does the problem occur with any HTML file, or with some certain ones?
Can you attach a sample project that shows up the problem?


0

I've tested and it only happens with the HTML/CSS file I am working on, does not matter if it is in the current project I am developing or in a new one. I can not attach it. It's a rather big file (~1000 lines). Could it be because of the warnings WS throws at me? WS suggests to recombine elements together but that does not suit me.

Thanks for your time.

0

Fernando,

I have no idea what warnings you are talking about... Not sure if they are related to this LiveEdit issue. But definitely the problem has something to do with the file structure. If you can't attach a file because of its size, can you upload it to our ftp server, ftp://ftp.intellij.net/.uploads/, please?


Best regards,
Lena

0

No, I mean I can not attach it because I am not allowed to. Don't worry, this support was outstanding. I will try to isolate the problem on my own. I could provide feedback in case it is relevant.

Thanks again.

0

Thanks for update:)
Please let us know if you manage to isolate the problem - your feedback will be appreciated!

0

Please sign in to leave a comment.