Plugin failed to initialize, PHPStorm won't open

Hi - apols in advance, I'm new to PHPStorm.

I've installed the trial of PHPStorm 6.0.3 on Windows 7 Professional x64 with SP1.

I then downloaded the TFS Integration plug-in v129.105 from here - http://plugins.jetbrains.com/plugin/?webide&id=4578, and installed/ enabled it by pointing the plug-ins manager at the tfsIntegration.jar file (the online install wouldn't work due to an http error - perhaps due to our company's proxy server).

However, PHPStorm won't open now, and the following errors pop up over the initial splash dialog:

Plugin com.intellij failed to initialize and will be disabled:
Can't find bundle for base name org.jetbrains.tfsintegration.core.TFSBunsle, local en_GB
Please restart JetBrains PhpStorm

Plugin com.intellij failed to initialize and will be disabled:
Can't find bundle for base name org.jetbrains.tfsintegration.core.TFSBunsle, local en_GB
Please restart JetBrains PhpStorm

I've tried uninstalling and reinstalling the trial of PHPStorm 6.0.3 a number of times now (incluing a restart of Windows imbetween), but the application still throws the above errors.

Any advice on resolving this appreciated.

Many thanks in advance,

IR8

8 comments

Hi there,

You can delete unwanted plugins manually from C:\Users\USERNAME\.WebIde60\config\plugins folder.

Once PhpStorm is able to launch again -- try re-installing plugin (maybe it will work this time). Unfortunately I cannot advice why it fails.

Also -- check idea.log file for possible details: C:\Users\USERNAME\.WebIde60\system\log\idea.log

0

Thanks for your help Andriy

I can't find a plugins folder at that location on Windows 7 (SP1) - and there isn't a .WebIde60 folder within the user profile.  The only relevant one is C:\Program Files (x86)\JetBrains\PhpStorm 6.0.3\plugins, but there is not a TFS plugin listed.

0
I can't find a plugins folder at that location on Windows 7 (SP1) - and there isn't a .WebIde60 folder within the user profile


Well ... this is the folder where PhpStorm v6 should keep it's settings (on Windows 7): C:\Users\USERNAME\.WebIde60\ ... unless you have manually configured it to store them in a different place.

C:\Program Files (x86)\JetBrains\PhpStorm 6.0.3\plugins is for bundled plugins only (that come as part of PhpStorm by default).

If you cannot find it there -- do a global search for idea.log file or .WebIde60 then.

In any case: please try full uninstall (choose to delete config/settings files in PhpStorm uninstaller)

0
Thanks again Andriy.There turns out to be both a a .WebIde60 and .WebIde folder on the root of a personal folder on a file server share used for Windows folder redirection.However, we only use folder redirection for the Documents, Favorites and Desktop Windows folders, so it doesn't make any sense to me why it's dumped the PHPStorm config in the root of the containing folder.I only realised this when - through trial and error - I uncommented 'idea.config.path=${user.home}/.WebIde/config' in idea.properties.Upon re-opening PHPStorm, it prompted me for a location for an existing config - which it remembered was on the file server share!However, I chose the last option for a new config, and PHPStorm is running again.Do you have any idea why '${user.home}/.WebIde/config' would be interpreted as the root of a folder redirection share?
0

Sorry, I cannot really comment on your Windows configuration (not an admin guy) .. but it seems that when IDE asks for a user home folder, Windows itself gives it that path (unless... the user home folder path is computed manually from another standard folder by IDE).

In any case -- ~/.WebIdeXX folder (and especially system subfolder) must be located on fast local disk and not on network resource (IDE must have very fast and reliable access to cache/index files .. otherwise lags and freezes in very unexpected moments/out-of-nowhere are quite possible).

0
Thanks Andriy.  I think the behaviour is due to a Java bug - http://bugs.sun.com/view_bug.do?bug_id=4787931 - which means that user.home is ascertained from a Registry Key that stores the location of the user Desktop folder.Because the Desktop folder in this instance is forwarded to a file server share, Java strips the Desktop folder from \\fileserver\share\user\desktop - and returns user.home as \\fileserver\share\user.  The PHPStorm installer places .WebIde60 there.I can't see any way around this, other than to ask our Sys Admin to stop redirecting the Desktop folder to a file server share, can you?
0

You already have the solution: idea.properties file.

... I uncommented 'idea.config.path=${user.home}/.WebIde/config' in idea.properties. ...

Just provide FULL proper paths for config and system folders (they should exist when IDE is launching) that would be located on your fast local disk (for example: "C:\PhpStorm\config" and "C:\PhpStorm\system"). I have never done this myself (had no need at all) but in theory this should be enough ("plugins" and "log" folders should be properly calculated from those locations automatically).

P.S.
You will need to make sure that this file will have these settings when you install new/upgrade PhpStorm to the newer version (since this file is located in installation folder).

It's also possible to place such file in your user home folder. In such case IDE will take it from there ignoring (or maybe overwriting, not sure) same one from installation folder.

0
Many thanks Andriy.  Your suggestion seemed to work OK; amending idea.properties with specific paths within the user profile for config and system folders, then copying the whole .WebIde60 folder from the fileserver to the root of the local user profile.Wanted to make sure this was the right thing to do, and was in fact the only option.  Appreciate your help! IR8
0

Please sign in to leave a comment.