Changing web.xml location doesn't affect the .iml file

I still have not been able to get IntelliJ (build 1101) to save my web.xml
path correctly. I noticed that when I find the path and hit apply, it
appears in the text field which displays the path for that file. I add the
web resources directory and hit Appy and still the .iml file for this module
doesn't get updated. Its like IntelliJ just doesn't want to write changes to
the file.

Can anyone else confirm?

Content root: d:\dp
Resource dir: d:\dp
web.xml location: d:\dp\web-inf\web.xml
src files and output: d:\dp\web-inf\classes


--Grant


2 comments
Comment actions Permalink

Also, if I set the web.xml path to d:\dp\web-inf\web.xml and save it and
then exit and restart intelliJ, it ALWAYS goes back to d:\dp\web.xml which
doesn't exist.

My web.xml is read-only, could that be a problem?

--Grant


"Grant Gochnauer" <grant@gochnauer.org> wrote in message
news:bu4esl$15q$1@is.intellij.net...

I still have not been able to get IntelliJ (build 1101) to save my web.xml
path correctly. I noticed that when I find the path and hit apply, it
appears in the text field which displays the path for that file. I add the
web resources directory and hit Appy and still the .iml file for this

module

doesn't get updated. Its like IntelliJ just doesn't want to write changes

to

the file.

>

Can anyone else confirm?

>

Content root: d:\dp
Resource dir: d:\dp
web.xml location: d:\dp\web-inf\web.xml
src files and output: d:\dp\web-inf\classes

>
>

--Grant

>
>


0
Comment actions Permalink

I have been experiencing the exact same bugs you have mentioned on other threads related to web.xml resetting to content root and web root not saving. Unfortunately I am unable to start 1101 due to the startup problem so many others are having and I have no time to try the workaround. I am crossing my fingers and anxiously awaiting the next build to see if this problem persists. I have spent countless hours trying to figure out what combination of events cause this problem, but I can't find any scenario that will actually work, even though I have fellow team members that have the exact same setup and are having success.

Still waiting......

--Chris

0

Please sign in to leave a comment.