Keybindings not working

PHPStorm is great on Mac, but is completely unusable for me on my Linux computer: all keyboard shortcuts with letter keys are not working (i.e. a..z, though digit keys, space, etc are OK).
When I press Ctrl+Space inside PHPStorm it tells me "No suggestions" which is OK, but when I try any of Ctrl+X, Ctrl+P, Ctrl+W, Ctrl+L, etc, it doesn't react in any way. All menu items, toolbar icons, mouse bindings are working alright.
I opened Settings -> Keymap and tryed to add new keyboard shortcut to one of the actions. Again, when I press Space, digit keys or Escape, PHPStorm understands it and shows it in 'First Stroke' window. But when I try on of the letter keys, it says: 'Unknown keyCode: 0x0'.
phpstorm.png
There is nothing special in idea.log. This bug doesn't affect Eclipse
I've tryed with both OpenJDK and Oracle/Sun, Fedora 15 x64 and Ubuntu 11.10 x64 (same machine).
Related issue: http://youtrack.jetbrains.net/issue/IDEA-75450

Please tell me I'm doing it wrong (or there is a workaround). Should I change my keyboard?

UPDATE: I was wrong about NetBeans - it is actually affected by this problem

6 comments

Please reply a comment in the issue.

0

Love the drawing. :)

Im getting the same thing for my 'extra' keys along the top of the ergo4000 keyborad being used on kubuntu linux 12.04

http://www.flickr.com/photos/7140062@N04/404668598/

The silver keys along the top all give:
"unknown keycode 0x0"

I have the home button mapped to hide all the sidebars, but would like to use one of the other ones to turn on/off the debugger.  but with this key code error, all the keys give the same code so you can only use _one_ of the keys, not all of them.

0

i found the way to fix the problem — just move to Mac (actually, a lot of problems get fixed that way)

-1

Same issue here on Thinkpad W510 w/Ubuntu 13.04 running PhpStorm 6 or 7 (eap), java version "1.7.0_25". Also love your drawing  because that is what it feels like!

This issue seems related. https://java.net/bugzilla/show_bug.cgi?id=799

0

Please sign in to leave a comment.