EJB support in Aurora?

The support for EJB has been officially muted till the new modules
are in place. Then the modules were (are?) struggling to get right.

Now, I'd like to ask:
- is the EJB support officially back?
- will it be possible to have java module with all the bean classes
and interfaces and EJB module have just ejb-jar.xml?
(we need that for maintaining big codebase that has the beans
spread all over the package space)

So far, when I try to configure an EJB module (in 1050), I only get
a bunch of NPEs (in File.]]>). Reported in ITN.

r.

3 comments
Comment actions Permalink

Richard,
You might want to take this to the J2EE forum. But I have EJBs working fine since the late 900 builds. I have all my classes in a EJB Module (I deleted the default module). It works great. I think your project sounds a lot like ours, in which case the whole thing is actually a EJB module in the new module layout.

Thanks,
Patrick

0
Comment actions Permalink

I'm not smart...didn't notice I was reading the J2EE forum. :) Disregard that point.

Thanks,
Patrick

0
Comment actions Permalink

Hm, i've put the ejb-jar.xml into the module's root and things are much better
now. Still seeing some File.]]> NPEs when some settings (unused) are not
filled (e.g. CMP xml) but this is looking good.
Hope, the ejb-jar.xml location setting will get fixed soon.

r.

Patrick Burleson wrote:

Richard, You might want to take this to the J2EE forum. But I have EJBs
working fine since the late 900 builds. I have all my classes in a EJB Module
(I deleted the default module). It works great. I think your project sounds a
lot like ours, in which case the whole thing is actually a EJB module in the
new module layout.

Thanks, Patrick

0

Please sign in to leave a comment.