can't remove read-only status on win7


I get the message, that the file/folder I am working in is read-only and can't do anything against it. I tried:

a) File -> Make File writeable
b) set full permission through the windows user system
c) start phpstorm as administrator
d) use the popup to "use the filesystem to remove read-only status"
e) delete the project-file and let it recreate through phpstorm

And to be honest I have no idea why this happens. I can edit files just fine, but the project-file itself does not seem to get saved correctly, but the message is highly annoying.

Can you please advise how to fix this issue?

Thank you very much.

I) The button to create a new thread is hidden too damn well. took me 15 minutes to find it.
II) The html-editor does not work in Opera 12.16

Comment actions Permalink

Hi there,

If you are not using any VCS, then "read-only" status on Windows OS is determined by Read Only attribute on that file. Just unset it in Explorer .. and use "File | Synchronize" in PhpStorm to re-read project files.

BTW -- what kind of file it is? Is it part of any JS Library or something?

Comment actions Permalink


thanks a lot for your response. Unfortunately it didn't help. I removed the "write protection" as well as the user rights before, the former gets put back in place immediately, regardless how I try to modify it. Tried it again, didn't help. Synchronize does not show any effect.

I am not using a real VCS, but the files lie within my Dropbox folder. This worked just fine when doing the same thing on a Mac. I also just tried to do the whole thing with Dropbox on pause, but did not suceed either.

It indicates the whole folder as non-writeable. But I can save files just fine, so I assume that it is specifically the phpstorm-project file?

Would be glad for further input.


Comment actions Permalink

Sorry .. have no other ideas except
1) restarting your PC and
2) delete your project settings (.idea subfolder) while IDE is closed and then re-create the project from scratch (Open Directory)

I have never faced this problem myself .. and right now I do not remember seeing any similar issues.

Comment actions Permalink

Tried both of these before and again, but neither worked. But many thanks for trying to help!

Comment actions Permalink

I just found that I can't even create files from within phpstorm any more, but rather only am able to edit existing ones. This renders the program pretty much unusable to me. "Funny" part is that phpstorm can create the directory .idea and the file .name - but does not create anything else.   I bought this product as it was working very well on the mac I used before - but with the current status I can't continue using it. I would be happy if someone from the jetbrains staff could check this issue.

Comment actions Permalink

Check error log for possible details (Help | Show Log in Explorer) -- it may contain the hints.

Based on the Issue Tracker tickets -- so far you are alone with such problem (which means -- your computer-specific problem -- possibly 3rd party software like Backup; AntiVirus etc) -- have not seen any tickets with such problem in the last 3-4 months.

Comment actions Permalink

Well, seems like the same issue partly fits too

Updated to 7.0, did not help.
New Info: It seems to be a specific folder that does not work, other folders work just fine. No Backup software running, Dropbox deactivated, AntiVirus does not block other folder.

It somehow seems like only the specific, single folder to have this problem.

I will try to remove phpstorm as clean as possible and reinstall it again, perhaps then it accepts it.           

Comment actions Permalink

I had the same issue and spent a lot of time to find solution. I didn't realize that's so simple!

Please follow below steps:

1. Go to Database

2. Create SQLite connection, or open its properties

3. Open tab Advanced

4. Set open_mode=2 (which is the clue 2 means read-write mode)

5. Apply changes

Voila! It works!



Please sign in to leave a comment.