Expanding Collapsed areas upon Paste/Tab

Is there a way to prevent WebStorm from expanding every collapsed area in the IDE when you paste code in or tab to adjust indenting on highlighted code? I've looked through the settings to no avail. Sometimes it will keep collapsed areas collapsed, but most times it expands everything that has been collapsed and it is steadily changing from annoying to frustrating to infuriating when it does this.

1 comment

Hi there,

There is no special setting to prevent this -- this is just a bug and quite a few people facing it (at least I do remember seeing few tickets regarding unwanted expanding of collapsed blocks on edit; even facing it myself, but rather rarely since I usually do not use code collapsing).

Check the Issue Tracker (both PhpStorm specific and IDEA in general) for similar tickets .. or feel free to submit new one (if you can provide exact code and steps that would allow to reproduce the issue (at least after few attempts) -- this would be fantastic -- as it should increase the chances of this annoying behaviour to be fixed)

0

Please sign in to leave a comment.