custom tags in javadoc

In a project's properties, on the JavaDoc tab, why doesn't '-tag todo:-a-"To
Do:"' (without the outer single quotes) entered into the "Other parameters:"
edit field cause IDEA to accept the following javadoc line:

  • @todo: do something about the zombies


IDEA is showing me a red square in the upper right corner of the editing
window with a link to this line saying "Wrong tag".


1 comment

Dear Doug,

Here are some comments and tips regarding your problem:

1. Don't know, whether this is just a typo in your parameter string, but you
are obviously missing a colon sign between "-a-" and "To Do". If JavaDoc is
not generated for you, then this is the reason. Please check that you follow
the correct parameter syntax.
2. As for adding custom JavaDoc tags to be recognized by IDEA:
a) if you are working with IDEA 3.0, you would need to perform some
extra steps, that are probably not very obvious. Here you go:
- in the "IDE Settings" dialog, open the "Errors" pane;
- select the "Unknown javadoc tags" option under the "General" list;
here you can specify the way such tags to be highlighted in the editor ("As
errors" by default)
- in the "Additional JavaDoc Tags" field, specify custom tags to be
recognized by IDEA
b) in IDEA 4.0 you can easily use the corresponding Intention Action:
having a custom tag highlighted as a wrong one in the editor, just position
the caret on it, and the light bulb will appear (Alt+Enter) suggesting you
to add the current tag to the custom tags list.

Good luck!

Ann Oreshnikova,

JetBrains, Inc.
"Develop with pleasure!"



"Doug Beyer" <dbeyer@uxcomm.com> wrote in message
news:bpdjre$3ja$1@is.intellij.net...

In a project's properties, on the JavaDoc tab, why doesn't '-tag

todo:-a-"To

Do:"' (without the outer single quotes) entered into the "Other

parameters:"

edit field cause IDEA to accept the following javadoc line:

>

  • * @todo: do something about the zombies

>

IDEA is showing me a red square in the upper right corner of the editing
window with a link to this line saying "Wrong tag".

>
>


0

Please sign in to leave a comment.