0

Can I use PHP Storm to help the process of upgrading PHP

I have joined a team that has a large and old code base which runs on PHP 5.1.

We would like to upgrade our code to run on at least PHP 5.3 or 5.4.

Can I use PHP Storm to help with this ?

Currently I have a Mac and we run Centos 5.5 on Virtual Box. The actual PHP is located on the Mac and access by virtual box using a shared folder.

There seem to be a number of tools available like Code Inspector, and PHP Code Sniffer. (I know that PHP CS only runs on PHP 5.2)

My initial idea was to configure PHPStorm to use the latest PHP binary from MAMP, and then run code inspector, to olny highlight the depracated features.

Would this be the quickest way ?

Should I upgrade from 5.1 to 5.2 and then 5.3. or can I just upgrade the whole lot to PHP 5.4 in one go ?

William

0 comments

Please sign in to leave a comment.