How to run dart.build in WebStorm ?

Hello

I can't figure out how to run the dart.build (or any other dart) file in WebStorm.

The only option to run dart files seems to be DartUnit, but I think that is only for running tests.

I need to run the build.dart to create the WebUI Template output files.

It would also be great if it would be able automatically run this whenever a file changes (like the Dart Editor does).

Please help ;)

Cheers
Bernd

1 comment

Hello Bernd!

WebStorm 6.* doesn't support running Dart command line applications -  only web; so the cmd applications can only be run as a dart unit test. But you need to include  unittest dependency in your pubspec.yaml and install the corresponding  packages (using 'install packages' in pubspec.yaml right-click menu; you  should have all needed packages right in the project directory ) to be  able to run them.
Note that the upcoming WebStorm 7 will provide support for Dart cmd applications. You can download the recent EAP from http://confluence.jetbrains.com/display/WI/WebStorm+7+EAP
Best regards,
Lena

0

Please sign in to leave a comment.