Can't type left curly bracket

Hi, I'm new here and I had downloaded a phpStorm as trial version. I think it's very good IDE but if I create a new project for example, I can't type left curly bracket { and I don't really know why while in another IDE (NetBeans) or just in notepad works everything fine. The same problem is with sign of greater-than >. If I try type sign > I get message "There are no custom folding regions in the current file". I'm using Windows 7 so I would like to ask where is problem. Thanks for reply.

6 comments
Comment actions Permalink

Set `actionSystem.force.alt.gr` to true in Registry (Search Everywhere -> type "Registry" -> click "Registry..."). This will force whatever your keyboard layout understands as AltGr+Key instead of PhpStorm's hotkey (e.g. for Czech keyboard AltGr+E => €, AltGr+F => [, etc.). Unfortunately, you'll not be able to use predefined hotkeys with AltGr. But they are easy enough to remap to a different key in Settings. 

7
Comment actions Permalink

Sorry for that, please follow the thread to be notified on progress: https://youtrack.jetbrains.com/issue/IDEA-166723

1
Comment actions Permalink

Hi there,

If I try type sign > I get message "There are no custom folding regions in the current file"

Seems to me that there is some problem with keyboard or keyboard layout ... because default shortcut for "Custom folding region" is Ctrl+. ... and you trying to press Shift+. (to enter > symbol)

What is your keyboard layout / language in Windows ? Try setting it to "US English" (or whatever English is better suited for you there).

I know that there are some problems on some keyboard layouts (e.g. it's problematic to enter to enter Ctrl+/ on German layout) .. but have not heard anything about problems with { or >


In any case:

  1. "Settings | Keymap"
  2. Make your own keymap (a copy of pre-defined one) -- this will allow you to modify it (as any pre-defined is fixed and cannot be modified)
  3. Search for actions that may have any shortcuts assigned to any keys with those characters (there is "search by key" functionality -- a button next to the "bin" icon on the top right, next to input box) and re-assign then another (different) shortcut.
0
Comment actions Permalink

Thank you very much, I was out of the desperate from this. It helped, but it's interesting that I had on keyboard shortcuts for > (which I use as Ctrl+period) some GotoCustomRegion, which is for shortcuts Ctrl+Alt+Period and for { (which I use as Ctrl+B) I had default some Implementation(s), which is for shortcuts Ctrl+Alt+B. By the way my language in Windows is czech so I'm using QWERTZ layout and I tried even use english keyboard layout but without result. But it's good now so once more thank you very much!

0
Comment actions Permalink

I recently updated to the 2017.1 EAP and have the same problem on all jetbrains products: WebStorm, PhpStorm, IntelliJ !

0
Comment actions Permalink

Thanks Tomáš! I was getting desperate!

0

Please sign in to leave a comment.