Zen Coding / Emmet broken in 6.0?

hi,

i've been using phpstorm for two months now but i don't get the zen coding / emmet working. i've enabled it in settings > emmet ("Enable Emmet") and tried it with all possible keys (tab, enter, space) for "Expand abbreviation with". nothing worked.

when i have an html-document and type for example ul>li*3 and hit tab, then the line is cleared and that' it. today i tried a tipp from this post http://devnet.jetbrains.com/message/5482142#5482142 (reimporting my WebIDE directory) and now i have another result after hitting tab: nothing happens (it's making a tab). normally i should get:

<ul>
     <li></li>
     <li></li>
     <li></li>
</ul>

i appended a screenshot.

i've seen that "Live Templates" has the same key setting ("Tab") - could this make problems?

i would really love to use emmet in phpstorm, but i don't get it. is it a bug or am i doing something wrong?

thank you for some tips.

Robert



Attachment(s):
Bildschirmfoto 2013-06-04 um 09.14.42.png
5 comments

Hi there,

Looks like it's misconfiguration / settings on your end.

What that green background inside the whole <body> tag? If you place cursor just after <body> and press Alt+Enter on it, what do you see (screenshot please)?

0

I made a screenshot like you said. And i appended two further screenshots of an older html file out of my project. Here the effect after pressing "Tab" ist different: the row (ul>li*3) dissappears and a light bulb symbol appears. I clicked the symbol so you can read the tip.

Thanks in advance for helping!



Attachment(s):
Bildschirmfoto 2013-06-04 um 11.49.48.png
Bildschirmfoto 2013-06-04 um 11.58.48.png
Bildschirmfoto 2013-06-04 um 11.58.09.png
0

I'm referring here to your first screenshot. On your other screenshots I do not see such background .. so cannot comment for all of them.


You clearly have some custom Language Injection there, which most likely will prevent Emmet working there (since most likely that would not be html/css context anymore -- based on screenshot you have JavaScript instead of HTML there).

  1. Go to "Settings | Language Injections"
  2. Look trough all custom entries there (the one that has "global" or "project" in last column -- ignore "bundled").
  3. Disable all of them (for now -- you can re-enable most of them later). If you post screenshot of that settings screen here I may be able to tell which one maybe messing thing up (I believe it is the reason).
  4. See if it works now (should be)


You may just choose "Uninject Language" from that Alt+Enter menu -- it should work as well. But it just disables that single entry in Language Injections, while going manually trough them may reveal other possibly conflicting injections that you may have there (since I do not see green backgound on other screenshot, but that possibly due to the actual color scheme).

0

+1 to Andriy comment. Green backgrond indicates language injection, anf it seems that javascript is injected - and Emmet will only work in HTML/CSS context. Just try Alt+Enter, un-inject language and see if this solves the problem

0

YESS! It works now! You made my day :-)

For now i just tried ""Uninject Language", but also in the other document (other screenshots) it works now!

Thank you so much...

0

Please sign in to leave a comment.