Can't see .gitignore files

For some reason, I can't see .gitignore files.  I'm using PhpStorm 6.0.2.  I'll be the very first to admit I probably set it up that way somehow in my configuration, but for the life of me I just can't find out where it's happening to fix it.  I can see .htaccess files fine so it doesn't seem to be anything to do with files beginning with '.', which leads me to believe it's very specifically .gitignore.  Is this a PhpStorm setting or something I screwed up on my own? :p

Thanks!

7 comments
Comment actions Permalink

Also, if it helps any, this happens for any new projects I create as well as existing ones, so whichever setting it is, it appears to be IDE-wide, not project-specific.

0
Comment actions Permalink

Hi there,

For some reason, I can't see .gitignore files.

I'll be the very first to admit I probably set it up that way somehow in my configuration, but for the life of me I just can't find out where it's happening to fix it.


Please check patterns in "Settings | File Types | Ignore files and folders" field (bottom of the screen) -- maybe you have added it there (the most likely place as far as I see it).

1
Comment actions Permalink

You, sir, are a gentleman and a scholar.  I spent ages trying to find that.  I put "Ignored" in the filter and it pulled up the deployment ones, but not that one, probably because I had "Ignored" instead of "ignore".  Thank you very much :)

0
Comment actions Permalink

@Andriy Bazanov your solution didn't help in my case. I have "Dockerfile" line in the .gitignore file because it gets generated and I'd like to view it in Intellij. The "Ignore files and folders" option doesn't contain Dockerfile:

*.hprof;*.pyc;*.pyo;*.rbc;*.yarb;*~;.DS_Store;.git;.hg;.svn;CVS;__pycache__;_svn;vssver.scc;vssver2.scc;

Is there any other setting that I can try adjusting in Intellij?

0
Comment actions Permalink

@Aleksandar Kasabov

Hard to say right now. To start, show a screenshot of the Project View panel (whole toolwindow) and the same folder in your File Manager. Maybe it's some option/wrong scope etc.

A file named "Dockerfile" should be listed just fine (does for me on Windows).

That option before tells IDE to completely ignore such files & folders. If such name is not there ... then it must be something else.

P.S. Do you have .ignore plugin installed and active? Quite likely it will be responsible for this behaviour.

0
Comment actions Permalink

Thanks for the prompt reply, Andriy. Here are 2 screenshots proving that the Dockerfile exists but is not listed in the project view (it says "2 hidden" files).

Did you try adding the Dockerfile to .gitignore to see if it's shown on your Windows box?

PS: yes, .ignore is installed and you must be right about it being the culprit, checking into its options now

0
Comment actions Permalink

@Andriy, you were totally right. Checked the docs of .ignore plugin, turns out I had to right-click on the .gitignore file and select "show ignored file":

Thanks for the attention.

0

Please sign in to leave a comment.