How to debug in WebLogic

I know how to set up WebLogic to report debuggin events using JVMDI. I would
like to debug my IntelliJ EJB's.

What I don't know is how to start my code in debug mode and specify and
change break points?

Thanks/Victor Grazi


6 comments
Comment actions Permalink

Create a Remote run configuration in IDEA, start Weblogic with the VM options copied from the text area at the top of the
configuration's dialog. After Weblogic starts, just connect to it with the debugger by pressing "Debug" button.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"

"Victor Grazi" <victor.grazi@verizon.net> wrote in message news:bc7cgo$d58$1@is.intellij.net...

I know how to set up WebLogic to report debuggin events using JVMDI. I would
like to debug my IntelliJ EJB's.

>

What I don't know is how to start my code in debug mode and specify and
change break points?

>

Thanks/Victor Grazi

>
>


0
Comment actions Permalink

Hi Eugene,

I am curious how you did it. I got this error when I tried.
Failed to connect to target VM at 'localhost:7001' using socker transport.

I started weblogic with the following jvm option

-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=7001.

I got this error in weblogic console.

]]> <Connection failure.
java.io.IOException: A complete message could not be read on socket: 'weblogic.servlet.internal.MuxableSocketHTTP@17ac3e
5 - idle timeout: '60000' ms, socket timeout: '5000' ms', in the configured timeout period of '60' secs
at weblogic.socket.SocketMuxer$TimeoutTrigger.trigger(SocketMuxer.java:734)
at weblogic.time.common.internal.ScheduledTrigger.run(ScheduledTrigger.java:243)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:317)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:97)
at weblogic.time.common.internal.ScheduledTrigger.executeLocally(ScheduledTrigger.java:229)
at weblogic.time.common.internal.ScheduledTrigger.execute(ScheduledTrigger.java:223)
at weblogic.time.server.ScheduledTrigger.execute(ScheduledTrigger.java:49)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:178)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:151)

Any idea?

Thanks.

Arsel

0
Comment actions Permalink

Arsel wrote:

Hi Eugene,

I am curious how you did it. I got this error when I tried.
Failed to connect to target VM at 'localhost:7001' using socker transport.

I started weblogic with the following jvm option

-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=7001.


7001 is the default Weblogic port so if you're using the default, the
above might conflict with weblogic. Have you tried another port number?

/Daniel

0
Comment actions Permalink

Use the default port, I think it's 5005

-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005

0
Comment actions Permalink

Probably the 7001 port is in use already. If you are not sure what port to use, just don't specify the "address" parameter.
Weblogic's VM will pick a free port and print its number to the console. You can use this port for further attachements.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Arsel" <no_mail@jetbrains.com> wrote in message news:14813657.1061411081645.JavaMail.itn@is.intellij.net...

Hi Eugene,

>

I am curious how you did it. I got this error when I tried.
Failed to connect to target VM at 'localhost:7001' using socker transport.

>

I started weblogic with the following jvm option

>

-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=7001.

>

I got this error in weblogic console.

>

<20-Aug-2003 2:12:47 o'clock PM EDT> <Error> <HTTP> <BEA-101083> <Connection failure.
java.io.IOException: A complete message could not be read on socket: 'weblogic.servlet.internal.MuxableSocketHTTP@17ac3e
5 - idle timeout: '60000' ms, socket timeout: '5000' ms', in the configured timeout period of '60' secs
at weblogic.socket.SocketMuxer$TimeoutTrigger.trigger(SocketMuxer.java:734)
at weblogic.time.common.internal.ScheduledTrigger.run(ScheduledTrigger.java:243)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:317)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:97)
at weblogic.time.common.internal.ScheduledTrigger.executeLocally(ScheduledTrigger.java:229)
at weblogic.time.common.internal.ScheduledTrigger.execute(ScheduledTrigger.java:223)
at weblogic.time.server.ScheduledTrigger.execute(ScheduledTrigger.java:49)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:178)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:151)

>

Any idea?

>

Thanks.

>

Arsel

>
>


0
Comment actions Permalink

Hi Eugene/Jim,

I deleted the address in the java option and weblogic assigned a listening port for dt_socket then I used that port and it worked.

Thank you very much guys.


Arsel

0

Please sign in to leave a comment.