HTML files with capital letter -> no code highlighting?

When I name a HTML file to something like "EventController.html" - starting with a captital "E", code highlightning will not work and the icon changes to a blue something. As soon as the file is renamed to a title starting lowercase, everything is fine.

Is this an intended behaviour? How do I have to think about that to understand this behaviour?
Thanks for any insights!

Best,
Robert

7 comments

Hi there,

To start with: please show screenshots of such files (I mean -- file type icons).

Also -- does this happens with that file ONLY .. or with ANY file that starts with capital letter?

0

Well, did you try? What is happening in your phpstorm? Any changes in file type? Or do I get from your message that this is a NOT intended behaviour? - And yes, so far it only happens with html files, otherwise I would have posted it.

Sorry, but your questions are not really an answer...

0
Sorry, but your questions are not really an answer...

Maybe because they are actually "questions"..?

Well .. since you are expert here and definitely know how to sort it out... then I can only apologies for wasting your (possibly invaluable) time. GL further.

0

I asked questions and expected answers here - that's the idea of a forum, at least in my opinion. I did answer yours, you didn't anser mine. Fazit: not really helpful for me. So: did you try? Any similar behaviour? Or is this a bug that has to be filed?

0
I asked questions and expected answers here - that's the idea of a forum, at least in my opinion.

I agree with you.

I did answer yours, you didn't anser mine.

You did NOT. I still do not see neither screenshot or answer on my (very specific, I believe) question. Instead I saw counter-questions about my setup and something that only partially addresses my question.

Or is this a bug that has to be filed?

Purely based on your description (since I still do not see ANY screenshots -- maybe you forgot to attach them?) I can say that very likely (99.9% IMO) that this is just a misconfiguration on your end and not a bug (regardless of how such misconfiguration happened).

Right now (without having answers to my questions) I only have this idea:

  1. Settings | File Types
  2. Check every file type entry that has that "blue something" icon (there is a few file types that have "blue something" icons, hence I cannot give you more accurate description). But let's assume that it is "Text file" icon.
  3. Check the patterns in bottom list -- quite likely that you will have "EventController.html" (or very similar) entry there.
    • If so -- remove it.
    • If not -- then my guess is invalid.
0

You're right - I should have mentioned that it's the file icon!
Good man - your assumption was right! Thanks!

0

Please sign in to leave a comment.