Problem with PhpStorm 6 an Xdebug

Hi!
I have followed a lot of how-to, link and a lot of other stuff but I can't resolve my problem:
Xdebug don't follow the breackpoints in PhpStorm and the debugger console still wit message: "Waiting for incoming connection with ide key 'NUMBEROFKEY'.
The key are the same of the xdebug session key 'XDEBUG_SESSION_START'.

I have configurated a 'Php Web application' on phpStorm.

* I have a symfony2 installation
* my project folder are: /home/user/www/project/
* the virtualhost 'project' point to /var/www/project that point (symlink) to /home/user/project/www
* my server configuration in phpStorm point to project/app_dev.php

when launch the debugger the browser go to corretc point but the i guess the connection from xdebug to phpstorm is breaked...

my xdebug configuration:

zend_extension = /usr/lib/php5/20100525/xdebug.so
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_autostart=1
xdebug.var_display_max_children=512
xdebug.var_display_max_data=32000
xdebug.var_display_max_depth=8
xdebug.remote_port= 9199
;xdebug.profiler_enable=1
xdebug.profiler_output_dir="/tmp/xdbg.log"
xdebug.remote_host=127.0.0.1

Please help me!

7 comments

Hi there,

If everything is local (on the same computer/OS) then all what you need is these 2 articles -- it works if following them precisely (very little (if none) pre-configuration from PhpStorm side is required, and standard xdebug configuration, nothing fancy at all).


If followed, when xdebug will initiate debug session, the IDE will ask for path mappings -- just choose correct paths (required since you have symbolic links in use)

P.S.
I see you are using non-standard xdebug port -- I hope it is the same as in PhpStorm settings ?

0

Thank you but still don't work...

at the point 7 of this how-to http://confluence.jetbrains.com/display/PhpStorm/Zero-configuration+Web+Application+Debugging+with+Xdebug+and+PhpStorm nothing appens...

I have removed all the configuration apart the server configuration.
why i don't have an error message, a feedback...it's frustrating

0

About the xdebug port: yes in settings->php->debug->xdebug->port I have the same value

0

I don't know how, but after I have restarted firefox all work fine ! :O
:O

0

Well .. since I'm here and do not see what you have actually got there, I would suggest these steps:

  • Collect log from xdebug side -- it will tell if xdebug tries to communicate and where (address:port): http://xdebug.org/docs/all_settings#remote_log
  • Confirm that PhpStorm is the one who actually listens on xdebug port (e.g. from output of netstat command (or whatever is used on Linux)) -- that's after you activate "Start Listen PHP Debug Connections"
  • Try to connect to that IP:port using telnet
  • Don't forget to restart PHP/Apache after making changes to php.ini (in case they are not reloaded automatically) -- that's assuming that you are editing correct php.ini (some distros have separate php.ini for CLI and Apache)
0

Good.

Although I do not know how restarting browser could actually help here (have not met such cases myself).

0

Please sign in to leave a comment.