I installed the Markdown plugin, but I can't see the preview tab

Hi all,

Like the subjects says, I installed the Markdown plugin, but I can't see the preview tab.

If you look at the plugin page for the Markdown plugin, it shows several screenshots. There is one that demonstrates that you can expect two tabs at the bottom of your *.md file. One for text editing and one for preview. I only see the text editing tab, not the preview tab. What did change after installing the plugin was the highlighting of the file in the editor tab. This is as expected. However, I was looking for the preview. I would not like to purchase yet another editor just for Markdown. Any help appreciated.

I am using PhpStorm 6

Thanks,

Bart

13 comments
Comment actions Permalink

Works for me: PhpStorm v6.0.1 EAP build 129.91; Windows 7 x64;
screen01.png

0
Comment actions Permalink

I will try on windows. The question originated on a Mac. [Edit] On windows, it's exactly the same as on the Mac: no preview tab, but my build is older than yours. Anyone knows if I can turn the preview tab 'on' somewhere?

0
Comment actions Permalink

I have some Mac OS (10.7.x) as VirtualBox machine (takes forever to boot, but did the job for what I got it for) -- I've tried it there (clean install) and it works fine as well (I mean -- I do see tabs)

screen02.png

0
Comment actions Permalink

Thanks for taking so much effort in trying to reproduce my case. I'll check for updates of PhpStorm, my build is behind yours ... see if that helps. PhpStorm is telling me I have the latest version, but your build is later. I have 127.100 (6.0). You have 6.0.1, I think I saw that come by somewhere. Yes, in the early access program. Will try that one: http://confluence.jetbrains.com/display/PhpStorm/PhpStorm+Early+Access+Program

Tried it, but with no difference... Clean installation of EAP version, option for Markdown plugin accessible and working, but no preview tab.

0
Comment actions Permalink

Finally found a hint. There was something with my editor pane layout. When I tried split mode (which I don't want) then I get the tabs in the right pane. I suddenly realized I wasn't seeing *any* tabs, not even the text tab. So everything was working, I just couldn't get the right panel layout. After clicking 'unsplit' the tabs remained!

2
Comment actions Permalink

Brilliant, Bart. So the solution is to enable split view once, close the bugged split view, and then it keeps working (even after restarting).

0
Comment actions Permalink

They have built in Markdown support today I think, I switched to that.

0
Comment actions Permalink

The one built in now is the one which has this bug.

0
Comment actions Permalink

Ah, I wasn't aware of that. It never stopped working after my workaround.

0
Comment actions Permalink

Split view revealed the desired preview panel on new view.  So I just closed the editor without the preview.

I was using the build-in markdown plugin.

Thanks.

0
Comment actions Permalink

Had the same issue. The problem was that intellij detected my README.md file and automatically isntalled two different markdown plugins which didn't work both at the same time. When I restarted intellij I got the errormessage about this and was able to choose which one I want to use. After that I hat to close my README.md file in the editor and restart Intellij again. Then I opened the README.mg file and the markdown plugin was working perfectly fine.

0
Comment actions Permalink

The answer of Bart McLeod (Created April 03, 2013 15:56) https://intellij-support.jetbrains.com/hc/en-us/community/posts/207052595/comments/206969435 did the work provided I clicked Unsplit All instead of Unsplit.

0

Please sign in to leave a comment.