How can I set local server and remote server at the same time?(solved)

Hello everyone,
     I meet a problem about configuration of server in Webstorm. e.g. I want to create a project that need uploading to remote server, but I also want to view and test it on local server. I've already setup a local server and set the project folder in its root directory. What confuses me is when I set the remote server, the preview page is directed to local folder directory, e.g.
file:///F:/PHPnow-1.5.6/htdocs/webfly/flynavi/start.html#share  Only when I set Tools-Deployment-Configuration's Type as "Local or Mounted folder", it can be opend in local server path, e.g. http://localhost/webfly/flynavi/start.html

Can I set local and remote server together, that is to say IDE would open a page in local server path when I click Web Browsers icon in html editor as in Fig ?  


It is not a serious problem, and I only want to omit the step to type loca server path in browser's address bar.

Sorry, I find the solution, that is to set Tools-Deployment-Configuration's Browser Files on Server and Mapping's Web path on server perhaps. It's strange it didn't work not long ago but works now.

Unnamed QQ Screenshot20130508114131.png
Comment actions Permalink

Hello,  if you don't use autouploading, please try to set local server as default. Then browser should be ok, and to upload files to remote server use Upload to... and choose that server.

Comment actions Permalink

Hello Elena Shaverdova,
     I does as you describe, but when I select Tools-Deployment-Upload to... , the only appeared option is default local server, and I can't select remote server to upload as in Fig:
In fact I set several Deployment servers as in Fig:
and the more serious when I upload to the only server, the current project files' contents are all set empty so that I have to revert it. What's wrong with my operation?

Comment actions Permalink

Those other deployment entries (flynavi_lan_server & flynavi_test) -- do they have mappings set correctly? Double check that (that none of those Deployment entries have warnings/errors on ALL tabs) as it works just fine here.

Comment actions Permalink

Hello Andriy Bazanov,

     Maybe you're right, the upload to... functionality works now. Thank you very much. Now I do as you suggest: test code by local server and upload the project code by Tools-Deployment-Upload to ... and select the remote server.

     Best Regards


Please sign in to leave a comment.