6.0.1 Broken FTP

I was using PHP Storm 6.0.0 without any problems until I upgraded to 6.0.1 and now I've got FTP problems. I only have access to an IPv6 network and all my domains are mapped to an IPv6 address (Not available to outside of my network).

I'm currently running Windows 8 x64 with the most latest version of Java 7

I found this archive and tried a few things but nothing there seems to resolve my issue (http://stackoverflow.com/questions/6990663/java-7-prevents-ftp-transfers-on-windows-vista-and-7-if-firewall-is-on-any-idea)

When I setup FTP;

SFTP host: client.sitegoodies.org
Post: 22

entered the relevant details and in 6.0.0 this worked perfectly fine. Now as of 6.0.1 I'm receiving the error:

Connection to 'client.sitegoodies.org' fail.
Session.connect:java.net.UnknownHostException: client.sitegoodies.org

I also tried using just plain old FTP and FTPS which return:

Connection to 'client.sitegoodies.org' failed.
Host not found

So I figured something must be wrong on my side. ping client.sitegoodies.org returns as response as I expected [fd35:4776:6804:2:2::3] which is perfect and it's pinging. So I tried using Filezilla to the same host and it works without problems.

I enabled Debug in PhpStorm but didn't see much in the logs that would of helped me figure this out. I guess I can downgrade PHP Storm but I wouldn't be too happy about that.

I've attached the latest idea.log in case it helps anyone help me figure this one out.

Just to reitterate, 6.0.0 worked fine but 6.0.1 doesn't and nothing else has changed on the PC since upgrading.

Any ideas?



Attachment(s):
idea.log.zip
12 comments

Yes I have tried all of those options as well. The only option which isn't available to me is downgrading my Java version as I have several in-house programs built on-top of the 7.x branch.

As a further test, I just downgraded PHP Storm back to 6.0.0 and now everything is working again but I would really like to upgrade to the 6.0.1 of course.

I wish I could provide more details, I just don't know what else to give or try.

0

Hmm... Please, can you try the following:

- shutdown PhpStorm

- delete the idea.log

- enable debug logging for 'com.jetbrains.plugins.webDeployment' category (see
http://devnet.jetbrains.com/docs/DOC-1202 for details)


- recreate your problem and attach the idea.log
0

Thanks for sticking around, as requested here is the file per your directions.

I asked a buddy of mine if he could upgrade as he has almost the similar setup as I do but he only runs an IPv4 network and the upgrade works for him without any troubles. It appears something with IPv6 is borked someplace.



Attachment(s):
idea.log.zip
0

It's not the Java 7 issue and that has been fixed in PHPStorm anyway.

Your exeption is Session.connect:java.net.UnknownHostException: client.sitegoodies.org

Unknown host. I assume you use internal DNS since those servers are not available externally? What DNS server software are you using? Can you do an nslookup on that host name for me and give me the results?

0

@ Keith, actually I normally just use IP Addresses to access things on my network but since PHP Storm won't let me input an IPv6 IP Address as a hostname for the FTP Settings I simply added some hostnames which I own but don't use right now into my Windows Hosts file. So I wouldn't be able to return an nslookup for you. Best I can supply is a ping return:


C:\Users\Sammie>ping client.sitegoodies.org

Pinging client.sitegoodies.org [fd35:4776:6804:2:2::3] with 32 bytes of data:
Reply from fd35:4776:6804:2:2::3: time=1ms
Reply from fd35:4776:6804:2:2::3: time=1ms
Reply from fd35:4776:6804:2:2::3: time=1ms
Reply from fd35:4776:6804:2:2::3: time=1ms

Ping statistics for fd35:4776:6804:2:2::3:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms


and also if I telnet client.sitegoodies.org 22

SSH-2.0-OpenSSH_6.2

Even if it was DNS, if the 6.0.0 version works then I would have assumed the 6.0.1 would work just as well. That's the strange part!

Message was edited by: diemuzi

0

Wow. Just an FYI, don't put a bad host name in the deployment settings when Notify about remote changes is checked. I am trying to do some tests for this and it's locked up PHPStorm (had to End Task) 3 times now!

Anyway, I confirmed it's not anything to do with host file configuration you are using, it must be a bug doing hostname lookups on IPv6. I've run into problems with hostname lookups in a C# app that I maintain.

Have you filed a bug report?

0

I have not yet created a bug. I wanted to be certain that I wasn't loosing my mind first.

Also there are no bad hostnames that I can find here. Everything resolves and everything is local based, nothing ever reaches the outside world. I also only use domains which I actually own, regardless if someone can use them from outside the network or not.

0

Understood. I found a few Java IPv6 bugs on the Internet, but all of them look old and not applicable. If I had to guess, the hostname lookups are not being handled correctly, either it's only attempting to use IPv4 or something like that.

0

Hello!

Could you try to add JVM option

-Djava.net.preferIPv6Addresses=true and remove -Djava.net.preferIPv4Addresses=true. The latter option was added in PhpStorm 6.0.1. Maybe exception occures because of trying to work with IP4 in your environment.

Also please ensure that your PhpStorm 6.0.1 is not blocked by your firewall.
0

Yes, that did the trick! FTP is now working again. Thank you! =)

As a side question, would it be possible in the near future to use IPv6 IP Addresses as the hostname when setting up FTP instead of using actual domain names?

0

Great! It is not planned in the nearest future, but i've created an issue for it, feel free to vote and watch it.

0

Please sign in to leave a comment.