shortcut for ant task

Hi,
I'm trying to assign a shortcut to an ant task that I have. I've opened
options->keymaps expanded "Ant Targets", but I could obly find ]]> in there. I also found that the "Add Keyboard Shortcut", "Add Mouse
Shortcut" and "Remove" to be disabled - how do I make them enabled?
It's all build 689.
Thanks.


6 comments
Comment actions Permalink

WRT shortcuts to Ant targets, IDEA imposes an additional constraint on Ant
buildfiles in that the "name" attribute of the element is required instead of optional. Check your buildfile to see if your has a "name" attribute and if not, try adding one and seeing if that helps matters. Kendall "Zohar" ]]> wrote in message
news:auuqvn$nj4$1@is.intellij.net...

I'm trying to assign a shortcut to an ant task that I have. I've opened
options->keymaps expanded "Ant Targets", but I could obly find <default
target> in there. I also found that the "Add Keyboard Shortcut", "Add

Mouse

Shortcut" and "Remove" to be disabled - how do I make them enabled?
It's all build 689.
Thanks.



0
Comment actions Permalink

It already has a "name" attribute.
what I actually see is:
(-)Ant Targets
(-)messenger (the project's name)
I have a few targets in that project - it's not empty... And the point is that I never get the shortcut control keys enabled, they are always disabled, which means I can't map anything to any shortcut - any reason for that? Thanks, Zohar "Kendall Collett" <7c9rg55p6h02@sneakemail.com>]]> wrote in message
news:auv6ps$5n8$1@is.intellij.net...

WRT shortcuts to Ant targets, IDEA imposes an additional constraint on Ant
buildfiles in that the "name" attribute of the <project> element is

required

instead of optional. Check your buildfile to see if your <project> has a
"name" attribute and if not, try adding one and seeing if that helps
matters.

>

Kendall

>

"Zohar" <david_fire4@hotmail.com> wrote in message
news:auuqvn$nj4$1@is.intellij.net...

I'm trying to assign a shortcut to an ant task that I have. I've opened
options->keymaps expanded "Ant Targets", but I could obly find <default
target> in there. I also found that the "Add Keyboard Shortcut", "Add

Mouse

Shortcut" and "Remove" to be disabled - how do I make them enabled?
It's all build 689.
Thanks.

>
>


0
Comment actions Permalink

I think that the reason is that your targets are disabled. By default, IDEA
disables all targets that don't have description (private targets) but the
main target stays enabled. If you want to enable some/all targets, open the
ANT properties dialog and check the targets you want enable in the "Filter
Targets" tab.

"Zohar" <david_fire4@hotmail.com> a ?crit dans le message de news:
av0mrr$gs$1@is.intellij.net...

It already has a "name" attribute.
what I actually see is:
(-)Ant Targets
(-)messenger (the project's name)
<default target>

>

I have a few targets in that project - it's not empty...

>

And the point is that I never get the shortcut control keys enabled, they
are always disabled, which means I can't map anything to any shortcut -

any

reason for that?

>

Thanks,
Zohar

>

"Kendall Collett" <7c9rg55p6h02@sneakemail.com> wrote in message
news:auv6ps$5n8$1@is.intellij.net...

WRT shortcuts to Ant targets, IDEA imposes an additional constraint on

Ant

buildfiles in that the "name" attribute of the <project> element is

required

instead of optional. Check your buildfile to see if your <project> has

a

"name" attribute and if not, try adding one and seeing if that helps
matters.

>

Kendall

>

"Zohar" <david_fire4@hotmail.com> wrote in message
news:auuqvn$nj4$1@is.intellij.net...

I'm trying to assign a shortcut to an ant task that I have. I've

opened

options->keymaps expanded "Ant Targets", but I could obly find

<default

target> in there. I also found that the "Add Keyboard Shortcut", "Add

Mouse

Shortcut" and "Remove" to be disabled - how do I make them enabled?
It's all build 689.
Thanks.

>
>

>
>


0
Comment actions Permalink

I got them enabled - thanks, but...
1. What is and why is it still there? 2. The "shortcut control keys" (add/remove...) are still disabled, so I can't do anything usefull... "Regis Le Brettevillois" ]]> wrote in message
news:av0tq6$8hl$1@is.intellij.net...

I think that the reason is that your targets are disabled. By default,

IDEA

disables all targets that don't have description (private targets) but the
main target stays enabled. If you want to enable some/all targets, open

the

ANT properties dialog and check the targets you want enable in the "Filter
Targets" tab.

>

"Zohar" <david_fire4@hotmail.com> a ?crit dans le message de news:
av0mrr$gs$1@is.intellij.net...

It already has a "name" attribute.
what I actually see is:
(-)Ant Targets
(-)messenger (the project's name)
<default target>

>

I have a few targets in that project - it's not empty...

>

And the point is that I never get the shortcut control keys enabled,

they

are always disabled, which means I can't map anything to any shortcut -

any

reason for that?

>

Thanks,
Zohar

>

"Kendall Collett" <7c9rg55p6h02@sneakemail.com> wrote in message
news:auv6ps$5n8$1@is.intellij.net...

WRT shortcuts to Ant targets, IDEA imposes an additional constraint on

Ant

buildfiles in that the "name" attribute of the <project> element is

required

instead of optional. Check your buildfile to see if your <project>

has

a

"name" attribute and if not, try adding one and seeing if that helps
matters.

>

Kendall

>

"Zohar" <david_fire4@hotmail.com> wrote in message
news:auuqvn$nj4$1@is.intellij.net...

I'm trying to assign a shortcut to an ant task that I have. I've

opened

options->keymaps expanded "Ant Targets", but I could obly find

<default

target> in there. I also found that the "Add Keyboard Shortcut",

"Add

Mouse

Shortcut" and "Remove" to be disabled - how do I make them enabled?
It's all build 689.
Thanks.

>
>

>
>

>
>


0
Comment actions Permalink

I got them enabled - thanks, but...
1. What is <default target> and why is it still there?


This is the target that's defined in the ]]> tag.

2. The "shortcut control keys" (add/remove...) are still disabled, so I
can't do anything usefull...


Do you have created a new keymap profile? You can't override the "default"
one. You have to copy the default one (or another) and set it active.
Shortcuts and "execute on..." can be enabled via the ant tree view by right
clicking on any "enabled" targets.



0
Comment actions Permalink

Thank you very much - everything is ok now.
Hope to return the favor someday...

"Regis Le Brettevillois" <regis@libelis.com> wrote in message
news:av10ik$ce3$1@is.intellij.net...

I got them enabled - thanks, but...
1. What is <default target> and why is it still there?

>

This is the target that's defined in the <project ...
default="default-target" ...> tag.

>

2. The "shortcut control keys" (add/remove...) are still disabled, so I
can't do anything usefull...

>

Do you have created a new keymap profile? You can't override the "default"
one. You have to copy the default one (or another) and set it active.
Shortcuts and "execute on..." can be enabled via the ant tree view by

right

clicking on any "enabled" targets.

>
>
>


0

Please sign in to leave a comment.