Why my own javascript file be identified as a file without highlight?

I noticed that a javascript file with a suffix ".min" is a icon has "10101010" on it.Normal javascirpt file is a document.(Please take a look at the attachement).

BUT WHAT IS THE FXXK of the file icon with some columns in it?(please see the attachement) It looks like a "External Libraries" icon, but it's my own library!!! It doesn't highlight anything!!!

I try to "Mark as Plain Text",it turn into a document with blue lines.Then I "Mark as javascript",it first show normal javascript file icon,but instantly change to that FXXKING icon.NO HIGHTLIGHTING.

It's really piss me off.I don't know what happened and what to do.

Could anyone help me??



Attachment(s):
2013-04-23_094452.png
2013-04-23_094431.png
2 comments

I could be mistaken, but I think that is the file indicator for a minified javascript file.  It's a file that PhpStorm doesn't parse because the naming and such is so skewed from minification as to be useless.

0

Hi there,

I noticed that a javascript file with a suffix ".min" is a icon has "10101010" on it.Normal javascirpt file is a document.(Please take a look at the attachement).

It's an icon for minified files (or files that IDE recognizes as such). It has no inspections or other stuff enabled -- file is minified and not meant to be edited directly; and IDE has problems editing such files using full functionality.

BUT WHAT IS THE FXXK of the file icon with some columns in it?(please see the attachement) It looks like a "External Libraries" icon, but it's my own library!!! It doesn't highlight anything!!!

Yes, it's a library file icon -- you must have defined that file as part of some library in "Settings | JavaScript | Libraries".

By default there will be no syntax highlighting for the file (the original idea behind (if I'm not mistaken) -- you are using already made library, using it for reference (code completion) only and not for editing it).

You can ALWAYS bring full syntax highlighting back -- just click on Inspector guy in status bar and change slider position from "None" to "Syntax".

0

Please sign in to leave a comment.