Application debugging

Hello,


I have a problem with debugger not stopping at my breakpoints in my
application....(not is JSP's.., breakpoints is in actions under Struts.)

The statement at the breakpoint is:
"System.out.println("--


showlist--


");"
so that seems ok.

Web-app. enabled. IDEA restarted.
Breakpoints full red.

when i reach the breakpoint, the breakpoint gets a grenn cross on top of it.
Read help. according to help code could be out of sync. , checked for that
and that seemed to be okay.


runnning Weblogic 6.1 idea # 688 with remote debugging with stanard
parmaters:

-Xdebug -Xnoagent -Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005


it connects ok.


Any Ideas ?

/Frank Bengtsson

1 comment
Comment actions Permalink

Read all the groups regarding this problem and found the solution....

Enable debug-info when you compile !!!!!!!!!!!!!!!1

/Frank

frank wrote:

Hello,


I have a problem with debugger not stopping at my breakpoints in my
application....(not is JSP's.., breakpoints is in actions under Struts.)

The statement at the breakpoint is:
"System.out.println("---------showlist-------");"
so that seems ok.

Web-app. enabled. IDEA restarted.
Breakpoints full red.

when i reach the breakpoint, the breakpoint gets a grenn cross on top of
it. Read help. according to help code could be out of sync. , checked for
that and that seemed to be okay.


runnning Weblogic 6.1 idea # 688 with remote debugging with stanard
parmaters:

-Xdebug -Xnoagent -Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005


it connects ok.


Any Ideas ?

/Frank Bengtsson


0

Please sign in to leave a comment.