Start button is not working -

Hi all,

I have set up PHPStorm 5.0.4 for WAMPSERVER by using the following tutorial : http://wiki.jetbrains.net/intellij/Installing_and_configuring_XAMPP#Prerequisites .

Under Firefox I have downloaded the bookmarks (for Google Chrome I ahve added the extension Xdebug Helper). But when I click on 'Start debugger' bookmark (in Firefox/Chrome) nothing happens in PHPStorm.

I have followed the debugging steps explained in this video : https://www.youtube.com/watch?v=sP4dHAuq2kc .

My settings are :

File/Settings/Deployment :

Type : Local or mounted folder
Upload\download project files - Folder : C:\wamp\www\testproject
Web server root URl : http://localhost

File/Settings/PHP:
Name : php_from_wamp
PHP home:C:\wamp\bin\php\php5.3.13
Debugger : XDebug

I really do not see what is wrong....

Thanks in advance for your help,

MoonDragon

Ps : when on run debug, I can see the value of the variables.

4 comments

Hi there,

Well ... "Start Debugger" bookmarklet (or the same action in most browser xdebug extensions) does not actually launch debugger -- it just initiates xdebug cookie -- you still have to reload current page (or click the button/link; navigate to next page whatever) yourself -- only next request will be debugged.

Have a look at this manual (in case you have not seen it yet) -- I think it has enough info to have it running: http://confluence.jetbrains.com/display/PhpStorm/Zero-configuration+Web+Application+Debugging+with+Xdebug+and+PhpStorm

P.S.
If you are deploying your project file to another location (or symbolic links are used), then make sure that you have paths properly mapped in "Settings | PHP | Servers"

0

Hello,

I have read this tutorial equally but I do not know how to achieve this part 7. of this last (File/???):

"7. Set initial path mappings"


Ps : My project has been created from an existing folder/file (onmy pc only).

0

When debug connection will be received by PhpStorm .. and no Server defined yet in "Settings | PHP | Servers", then you will see that window poping up. If you have defined server entry in "Settings | PHP | Servers" manually already, then this window will not be shown. I suggest deleting any entries in "Settings | PHP | Servers" and try again -- quite often automatically detected settings are more correct than manually specified (especially if person is new to this functionality).

0

Hello,

Unfortunately its still not working for me...(I had removed the server settingss as advised...)

0

Please sign in to leave a comment.