647/648: NullPointerException while attempting to debug Tomcat 4.1.10

Similar problem as in other threads but unable to find resolution. Has anyone been able to solve this?

4 comments
Comment actions Permalink

I have a lot of error with Tomcat 4.1.10 debugging using IDEA 647. but 647 with Tomcat 4.0.4 JSP debugging is fine. it seems that it is the problem of Tomcat 4.1.10, but am lot sure.

0
Comment actions Permalink

Yes - same here. I moved my application to 4.0.x tomcat and all works well.

0
Comment actions Permalink

There was a post (subject was "Re: Tomcat 4.1 integration support IDEA Build
644?") in this newsgroup from Eugene Zhuravlev on Sep 9th that said:

"Yes, we'll make the integration compatible with Tomcat 4.1.
Probably 'Run' mode will be supported also."

So, maybe it's just a matter of not being implemented for 4.1 yet. But,
before you get too excited, see this post which sounds like 4.1 support will
be difficult or impossible:

http://www.intellij.net/forums/thread.jsp?forum=3&thread=8775&message=241970
#241970

chris

"Thomas Plunkett" <thomas_plunkett@yahoo.com> wrote in message
news:1983006.1032546263878.JavaMail.jrun@is.intellij.net...

Yes - same here. I moved my application to 4.0.x tomcat and all works

well.


0
Comment actions Permalink

before you get too excited, see this post which sounds like 4.1 support

will

be difficult or impossible:


Well, it is still possible to set up a Run configuration which will allow to
invoke Tomcat 4.1 in run/debug mode.
The difference is that you should specify "common/endorsed" directory
instead of "common/lib" when defining "java.endorsed.dirs" property (and
this was also the reason for the NullPointer mentioned in this thread if I'm
not mistaken).

As for JSP source-level debugging with this version of Tomcat - it turned
out that the current approach won't work.
Apache developers informed us that they are working on JSR45 support, but it
will be available only in Tomcat 5, which is under development currently.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


"Chris Bartley" <spam@feynman.org> wrote in message
news:amfrdo$qhu$1@is.intellij.net...

There was a post (subject was "Re: Tomcat 4.1 integration support IDEA

Build

644?") in this newsgroup from Eugene Zhuravlev on Sep 9th that said:

>

"Yes, we'll make the integration compatible with Tomcat 4.1.
Probably 'Run' mode will be supported also."

>

So, maybe it's just a matter of not being implemented for 4.1 yet. But,
before you get too excited, see this post which sounds like 4.1 support

will

be difficult or impossible:

>
>
http://www.intellij.net/forums/thread.jsp?forum=3&thread=8775&message=241970

#241970

>

chris

>

"Thomas Plunkett" <thomas_plunkett@yahoo.com> wrote in message
news:1983006.1032546263878.JavaMail.jrun@is.intellij.net...

Yes - same here. I moved my application to 4.0.x tomcat and all works

well.

>
>


0

Please sign in to leave a comment.