Did anybody manage to debug a WebApp in #638 yet?

I can configure a WebApp Debug Target and start the server (at least
the console output looks okay). When I try to connect to the server,
the browser keeps waiting for a response but nothing ever happens.

Michael

3 comments
Comment actions Permalink

I got a little further than you. I can can get to the Tomcat server but get
only "Apache Tomcat/4.0.4 - HTTP Status 500 - No Context configured to
process this request" errors. If I deploy the same code to the exact same
instance of Tomcat using Ant then all is okay but obviously no JSP
debugging. If I immediatley re-try the IntelliJ debugging I get the same
errors as before which seems puzzling to me as the working deployment is
still sitting in Tomcat. Help needed.

"Michael Descher" <michael.descher@gmx.de> wrote in message
news:i0c3kuk6kpggjv79timrq386ra6l6l1kc2@4ax.com...

I can configure a WebApp Debug Target and start the server (at least
the console output looks okay). When I try to connect to the server,
the browser keeps waiting for a response but nothing ever happens.

>

Michael

>


0
Comment actions Permalink

When you start the web app using the WebApp Debug Target then IDEA
will use the Tomcat configuration files in $\config\tomcat\

Since the server.xml file in this folder does not define your
context you get the 500 error described below. Just copy the server.xml
file from your Tomcat folder to this \config\tomcat\ and it should
work.

Marius

Arif Butt wrote:

I got a little further than you. I can can get to the Tomcat server but get
only "Apache Tomcat/4.0.4 - HTTP Status 500 - No Context configured to
process this request" errors. If I deploy the same code to the exact same
instance of Tomcat using Ant then all is okay but obviously no JSP
debugging. If I immediatley re-try the IntelliJ debugging I get the same
errors as before which seems puzzling to me as the working deployment is
still sitting in Tomcat. Help needed.

"Michael Descher" <michael.descher@gmx.de> wrote in message
news:i0c3kuk6kpggjv79timrq386ra6l6l1kc2@4ax.com...

>>I can configure a WebApp Debug Target and start the server (at least
>>the console output looks okay). When I try to connect to the server,
>>the browser keeps waiting for a response but nothing ever happens.
>>
>>Michael
>>




0
Comment actions Permalink

Well, you specify the context path in the web application
configuration. I solved the problem by correcting the IDEA.BAT file.
The classpath entry for velocity.jar is incorrect. It uses JAVA_HOME
instead of IDEA_HOME. After this it worked. You need not even deploy
the web app yourself into Tomcat. Although it works in general it
seems to be a little unstable at the moment. Sometimes I still can't
get it running, sometimes I have to remove the web app from the IDEA
caches.

Michael

On Wed, 31 Jul 2002 14:57:47 -0700, Marius Scurtescu
<mscurtescu@healthmetrx.com> wrote:

>When you start the web app using the WebApp Debug Target then IDEA
>will use the Tomcat configuration files in $\config\tomcat\
>
>Since the server.xml file in this folder does not define your
>context you get the 500 error described below. Just copy the server.xml
>file from your Tomcat folder to this \config\tomcat\ and it should
>work.
>
>Marius
>
>Arif Butt wrote:
>> I got a little further than you. I can can get to the Tomcat server but get
>> only "Apache Tomcat/4.0.4 - HTTP Status 500 - No Context configured to
>> process this request" errors. If I deploy the same code to the exact same
>> instance of Tomcat using Ant then all is okay but obviously no JSP
>> debugging. If I immediatley re-try the IntelliJ debugging I get the same
>> errors as before which seems puzzling to me as the working deployment is
>> still sitting in Tomcat. Help needed.
>>
>> "Michael Descher" <michael.descher@gmx.de> wrote in message
>> news:i0c3kuk6kpggjv79timrq386ra6l6l1kc2@4ax.com...
>>
>>>I can configure a WebApp Debug Target and start the server (at least
>>>the console output looks okay). When I try to connect to the server,
>>>the browser keeps waiting for a response but nothing ever happens.
>>>
>>>Michael
>>>
>>
>>
>>
>

0

Please sign in to leave a comment.