Remote Debugging issues

                                          Remote debug problems Phpstorm

PhpStorm is debugging locally, connecting through Wamp and firefox, break points no real issues.

I would like to debug on live site “www.....” , I built a couple of projects from existing code using

both the “ftp” and “web server is on remote host”. This seemed fine as the files where downloaded from the host to my local directory. I set break points “index” but this runs local files I know this as it tries to access my local database.

The relevant PHP.ini section

zend_extension = "c:/wamp/bin/php/php5.3.13/zend_ext/php_xdebug-2.2.0-5.3-vc9-x86_64.dll"

[xdebug]

xdebug.remote_enable = 1

xdebug.profiler_enable = off

xdebug.profiler_enable_trigger = off

xdebug.profiler_output_name = cachegrind.out.%t.%p

xdebug.profiler_output_dir = "c:/wamp/tmp"

; Trial for remote debugging got from storm disscusion group

; remove here if it toasts

xdebug.remote_port=9000

;xdebug.remote_connect_back=1

I am a newbie with php, phpstorm and developing on wamp.

Questions:

I have read that the Hosting site initiates the xdebug connection, this sort of suggest there maybe initialisation issues there as well ?

Port forwarding through the router? I not sure how to verify that this is ok other than accessing the router and looking at the moment this shows nothing but that could mean they are all blocked. Or how I could verify this would wire shark caputure this traffic

I would be very gratful for any pointers where I am going astray or more info if my explanation is missing relevant details

Thanks for reading

2 comments

Hi Bob,

Where this config is from -- your PC or actual remote server? You have to have xdebug installed, enabled and configured on remote server (where PHP script is actually executed).

If your site is hosted on some shared hosting, they very unlikely to have xdebug installed and enabled (as it slows down script execution).

0

     Thanks that clears up alot, I dont know why or how i expected this to work, the xdebug is on my local machine and the php is on the local machine.
    The site is hosted so i will talk to them as i need to debug some packets  that lands at that site. Again thanks

0

Please sign in to leave a comment.