New Foundation Project?

Hi,

I want to start a new foundation css framework project.
Setup copies the data from the Github repository to my directory, thats fine.
But there are no compiled *.css files available.

Recently I installes the sass support but where and how to start to compile the toolkit?

best regards
jo

6 comments
Comment actions Permalink

Hi there,

You have to install working SASS yourself, unfortunately -- IDE does not come with or supply it in any way.

When installed, you may configure it (sass compiler) to compile any changed *.sass/scss files into*. css automatically (e.g.

sass --watch style.scss:style.css)
. You can also use standalone Scout App for this purpose -- very handy tool indeed. Alternatively, you can setup External Tools (Settings | External Tools) and call such compilation from IDE manually when required.

If you are using EAP version of WebStorm 6 then you can use built-in File Watchers functionality -- it will help to setup file watcher that will call sass compiler every time you save sass file in IDE. If you are using PhpStorm (EAP version as well) then this plugin can be manually installed via "Settings | Plugins" (it will later be bundled with PhpStorm as well when v6 will be released). Some examples can be found here: http://devnet.jetbrains.com/thread/441671

As to haw to compiled Foundation CSS Framework, I do not know (never used it myself) -- you have to check this in their manual (but I doubt it will be any different from compiling any other sass files).
0
Comment actions Permalink

Hi,

I have the latest EAP of Webstorm (as of today), and I am trying to set up File Watchers for use with SCSS. The problem is that the File Watchers plugin is ignoring RVM and seems to default to Ruby 1.8.7 (I'm on a Mac) and not my RVM default: 1.9.3-p327. Is there any way to have the FIle Watchers plugin respect the RVM?

Thanks,

Timur

0
Comment actions Permalink

I think you can go to watcher settings(Preferences -> File Watchers -> SCSS double click) and specify an absolute path to a scss executable.

0
Comment actions Permalink

That is exactly what I did, but the sass executable is being handled by the system defualt ruby: 1.8.7.

0
Comment actions Permalink

I just solved the same problem on my mac by doing this.  in a terminal window, type

echo $GEM_PATH


Copy the path and put it into the file watcher config under environment variables.  When you enter it here, don't put the $ into the variable name (so the variable name would be GEM_PATH).  The value is what you got from above.

mkm

0
Comment actions Permalink

Thanks for posting this, Manish. This solved it.

0

Please sign in to leave a comment.