closing brace on typecasting $foo = (int)123;

This is an incredibly annoying feature/issue.
Does anybody know a workaround? Is there a setting I'm missing somewhere?
I posted a bug report but thought I got an email saying it was fixed.

Video of issue: http://www.screenr.com/NpE7

2 comments

There is no "proper"/easy-to-use workaround while still having this functionality enabled.

Only 2 solutions:

  1. Do not type closing parenthesis ")" yourself
  2. Disable automatic inserting closing parenthesis altogether -- Settings | Editor | Smart Keys


In any case: http://youtrack.jetbrains.com/issue/WI-12152

0

Thank you very much! I was unaware the automatic brace could be disabled. That will do fine :)

0

Please sign in to leave a comment.