PhpStorm 6 - Could not list the contents of folder...

Hello

I know this is probably a bug and belongs in the bug tracker, but as the bug tracker seems to be updating right now and not accessible, and i can't work with this issue i'll go along and post it here in the forum.

I just downloaded PhpStorm 6 today, and tried to connect to one of my stored Remote Hosts from before. It worked without a problem before i updated, but now i'm getting the error message "Could not list the contents of folder "ftp://[IP]/"
I tried some more servers, all of which worked before the update, and i get the same error message. I checked if something effed up the connection info, but all of that is correct and works in Filezilla and WinSCP.

Can anyone help me, or do i need to downgrade again?

I'm attaching a log file

Update: I just checked with a friend who updated his PhpStorm too, he has the same problem.



Attachment(s):
idea.log.zip
2 comments

Hello!

Looks much like http://youtrack.jetbrains.com/issue/WI-8453. If you use firewall, please ensure PhpStorm has permissions. If it has, try to use netsh advfirewall set global StatefulFtp disable or other fixes from http://stackoverflow.com/questions/6990663/java-7-prevents-ftp-transfers-on-windows-vista-and-7-if-firewall-is-on-any-idea

0

Hello Elena

Thank you! The netsh command fixed this for me.

Best Regards
Ramon

0

Please sign in to leave a comment.