Disable Local History

I have just downloaded phpStorm and stated using it and hit an issue I can't figure out.  The way I develop, the local history just gets in the way.  Is there a way to disable it so my changes will show up imediately?  So far I have only changed html files but I am assumeing that php and js works the same.

Thanks.

4 comments

Hi Jim,

As far as I know you cannot disable Local History.

But the main question is -- how is it getting in your way? Why do you think it prevents changes from showing up immediately?

0

Some more info.  I am using windows 7 and IIS 7.5. I have setup a project with three directories.  The first directory holds my common php code. The second is for my application php code and the last is for my website  that contains my html and js files.  I have also integrated the project with SVN.  It seems that the first two directories save just fine but the website directory will not save the changes to the file system. I can go to VCS->local history->show changes and see the difference between the version that I edited and the file system version. I can't seem to find a way to write the edited version back to the file system.  If I commit the changes to SVN, the file system changes are commited.  Restarting PhpStorm keeps my changes but I can't find a way to save them back to the file system. I tried to create a new project but the old project was used.

Thanks for you help.

0

I personally do not think it's a Local History issue at all. Simply speaking, Local History is a collection of .diff files, it cannot prevent file from being saved.

I'm also using Windows 7 (x64 SP1) and IIS 7.5 -- never had such issue in the past (but I do not use any VCS at all).

  • What IDE version do you use (Help | About)?
  • Do you see an asterisk next to file name in the editor tab (that's if "Settings | Editor | Editor Tabs | Mark modified tabs with asterisk" is enabled) when file is modified?
  • Is this folder is a symbolic (or another kind of) link by any chance?
  • Maybe you have antivirus/auto-backup/auto-index (local search) watching that folder -- try disabling them for a moment (I personally have PhpStorm whitelisted in my KIS 2013 -- it completely ignores PhpStorm and any activity from it -- this is mainly for performance reasons -- somethimes KIS makes some apps way to slow)
  • You said that the issue is with HTML files. Have you tried other file types? Maybe you are using Live Edit plugin's functionality (which possibly (although unlikely) can cause such behaviour (since it can "auto-save" files on its own, it will always be on my "check it" list))


Try these ideas:

  1. Make some change in a file (add extra space (and then remove it) or something like that) and explicitly invoke "File | Save" (Ctrl+S) action -- is anything happens (file got saved)?
  2. If nothing happened -- please check idea.log file for any hints (Help | Locate/Show Log in Explorer) -- maybe you will see some expceptions logged.
  3. Try disabling as many plugins as possible (start with 3rd party / not bundled ones) and see if it makes any difference. If does -- enable one by one until you find the one that causing this.
  4. Try a different simple project in another location (but under the same conditions).


If still nothing -- maybe it is worth filing a ticket to the Issue Tracker in such case then.

0

Thanks Andriy,

This is embarrassing.  Somehow while trying to set this up, I typoed the folder that holds my web site files and pulled all new ones from SVN and was editing the wrong files.  All is well now.

Thanks again for you help.

0

Please sign in to leave a comment.