How to type a pipe under Mac Os X with PhpStorm?

Hi,

I use PhpStorm since  shortly, I'm  under Mac Os X Snow Leopard and I can't type pipe (like this "|") under editor. If I use this combination (alt+shift+letter L), who runs with another editor, PhpStorm display a menu like "Lod Context (Press SHIFT to merge with current context)".

Do you have a  solution?
11 comments

Looks like this shortcut wasn't adjusted in OS X keymap. We already scheduled a review and fixing sessions for keymaps for all platforms.
In the meantime you can either change/remove it for you in Settings|Keymap panel or disable tasks plugin in Settings|Plugins if you don't use it.

0

Thank you, indeed I just needed to go in "File->Settings->Plugins" and to uncheck "Task Management".

0

Just use:
Alt+7

For me this work...

Greetings,
Urkman

0

Alt+7 correspond to "«" on my Mac Os X

0

I'm using a german system.
I get an "«" pressing alt+q

Greetings,
Stefan

0

It seems that this bug is still not fixed. After almost 3 years, it's not very cool :(

0

Ludovic, it should be fixed, see http://youtrack.jetbrains.com/issue/IDEA-54883.
Which IDE build version and Keymap (from Settings | Keymap | Keymaps) do you use?

0

Still not fixed in 2016.2 (PhpStorm 2016.2.1 Build #PS-162.1889.1, built on August 23, 2016), although the error changed : it now sorts the lines instead. Using Default keymap on El Capitan, french AZERT keyboard. This is likely a consequence of the Line sort plugin, so I just changed the mapping for the plugin to Ctrl-Alt-L instead.

0

Yup that's, the one. Added the issue on their Github, thanks.

0

Please sign in to leave a comment.