Adobe scripting preprocessor directives in WebStorm 5.0.3

Greetings to all!

The js-code for Adobe applications (Photoshop, Illustrator, Indisign...) include preprocessor directive., ie "C-style statement starting with the # character":

  #include "file.jsxinc"

  #includepath "include;../include"
  #script "testScript"
  #strict on
  #target photoshop
  #targetengine illustrator

Syntax checking module swears. Automatic code formatting divides these directives into three rows.
I tried to use eval("# include test.jsx"). This works for some directives, but not for all.

How do I make WebStorm not swear?

Thanks!

9 comments
Comment actions Permalink

For example, to make it clear what it was about, I attached screenshots.

Agree, it looks ugly;)

So how do I make peace webstorm with these specific directives?



Attachment(s):
ws_troubles_01.png
ws_troubles_02.png
0
Comment actions Permalink

Hi,

Could you submit your request to the tracker? http://youtrack.jetbrains.com/issues/IDEA. This would be the best way, as you will be notified on our progress and other's comments.

Kirill

0
Comment actions Permalink

Kirill, thank you!  I added a request to the tracker. I hope that is correct:
WEB-6095 preprocessor directives in JavaScript for Adobe applications
Now what?

0
Comment actions Permalink

Thanks for submitting!

Honestly I can't say how soon we will fix this, it very much depends on the feedback / votes this request gets. It's very important that now other users can see it and vote for it.

Kirill

0
Comment actions Permalink

How can they vote for it?

This means that there is no standard means of solving my problem (using settings and parameters WebStorm)?

It is clear that WebStorm is intended primarily for web programming. And not for scripting in Adobe design/prepress software. But it is super (cool, great ets) IDE and I can not give it up because of such trifles. Adobe standard tool (ESTK) awful.

0
Comment actions Permalink

There's a vote button on the ticket page (below issue title).
Unfortunately, there's no standard way, as these directives are not the part of the JavaScript language.

Kirill

0
Comment actions Permalink

Saw, thanks. There is a one person voted.
JS-code for Adobe professional design applications, write pre-press professionals, not professional programmers. So few of them use professional tools such as WebStorm. It is unlikely that the case will move forward.
In IntellijIDEA Ultimate same problem.

0
Comment actions Permalink

Problem solved by write directives in format of comments:

//@targetengine "session_01"
//@target illustrator
//@include "mylib.jsx"

Preprocessor sees the directive and at the same time is not broken syntax javascript.

0
Comment actions Permalink

Problem solved.  
I think the topic is closed.
Thank you for your help.

0

Please sign in to leave a comment.