Continuous OpenSSH Password Prompts

I have a project that I cloned from my web server.  Now whenever I have that project open, regardless of how many times I enter my password correctly, it'll continue to prompt me for my password 4 times every 5 minutes or so.  Is there a setting somewhere that I need to adjust to prevent this?  It's incredibly annoying.  I'd prefer to continue to use Git through PHPStorm, but if this keeps up I'll have to do something else.

6 comments

Do you really use ssh? Do you authenticate via password or via private key?

0

Yes, I am using SSH to push/pull via password.

0

So, is it true that do you get these password prompts without any activity from your side (like push, pull)?
Could you please attach idea.log (Help -> Reveal Log)?

0

Sure... here it is.  I'm using Ubuntu 12.10

2013-02-19 07:40:56,089 [  15892]   INFO - tor.impl.FileEditorManagerImpl - Project opening took 9334 ms
2013-02-19 07:46:02,661 [ 322464]   INFO - ea.execution.HgCommandExecutor - hg incoming --template {rev} {node|short} {author} {desc|firstline}   --quiet --newest-first
2013-02-19 07:46:02,663 [ 322466]   INFO - ea.execution.HgCommandExecutor - abort: no suitable response from remote hg!

2013-02-19 07:46:14,450 [ 334253]   INFO - ea.execution.HgCommandExecutor - hg outgoing --template {rev} {node|short} {author} {desc|firstline}   --quiet --newest-first
2013-02-19 07:46:14,451 [ 334254]   INFO - ea.execution.HgCommandExecutor - abort: no suitable response from remote hg!

2013-02-19 07:50:50,373 [ 610176]   INFO - s.impl.stores.FileBasedStorage - Document was not loaded for $APP_CONFIG$/intentionSettings.xml file is null
2013-02-19 07:50:50,373 [ 610176]   INFO - .impl.stores.XmlElementStorage - Document was not loaded for $APP_CONFIG$/intentionSettings.xml
2013-02-19 07:50:54,632 [ 614435]   INFO - ea.execution.HgCommandExecutor - hg incoming --template {rev} {node|short} {author} {desc|firstline}   --quiet --newest-first
2013-02-19 07:50:54,699 [ 614502]   INFO - ea.execution.HgCommandExecutor - abort: no suitable response from remote hg!

2013-02-19 07:50:57,704 [ 617507]   INFO - ea.execution.HgCommandExecutor - hg outgoing --template {rev} {node|short} {author} {desc|firstline}   --quiet --newest-first
2013-02-19 07:50:57,705 [ 617508]   INFO - ea.execution.HgCommandExecutor - abort: no suitable response from remote hg!

0

Ah, somehow I thought you were talking about Git, but now I see that it is Mercurial.
Unfortunately, SSH connections are not supported by Mercurial plugin yet: http://youtrack.jetbrains.com/issue/IDEA-56004
You'll have to use http(s).

0

Oh bummer!  Well... thanks for the help!  I guess I'll disable the plugin in the meantime.

0

Please sign in to leave a comment.