PHPStorm, IIS7 and Debugging

Hi All,

Is there a start to finish guide on configuring IIS7 and PHPStorm for debugging?

I've used the webplatform installer to install 5.3 and everythings working but im having real issues trying to debug through IIS.


Thanks

3 comments

Hi Steven,

Don't know if there is such A-to-Z manual for specific for IIS. As far as I 'm aware there is no difference from debugging or configuring php/xdebug point of view between Apache and IIS (I used both of them). The only thing you may want to do is to increase FastCGI process timeouts -- with default one debug session will be terminated by IIS in 30 seconds.

I'm using IIS 7.5, xdebug (2.2.1), PHP 5.4.11 and have no major issues.

If you have specific issue -- please provide details/configuration.

0

Thanks for the response..

I've managed to get a little further...

now this..



"C:\Program Files (x86)\PHP\v5.3\php.exe" -dxdebug.remote_enable=1 -dxdebug.remote_host=127.0.0.1 -dxdebug.remote_port=9000 -dxdebug.remote_mode=req C:\Users\Steve\AppData\Local\Temp\ide-phpunit.php --no-configuration C:\Users\Steve\PhpstormProjects\website
Testing started at 14:21 ...


Process finished with exit code 1
Cannot find PHPUnit in include path (.;C:\php\pear)

and Then in console window.


14:21:55 Unable to attach test reporter to test framework or test framework quit unexpectedly




Mean anything?

0

Hi Steven,

Please tell what you are trying to debug. The one above has nothing to do with IIS -- nothing at all (it is, as you can see, is CLI command, not web request).

From your message I see that you are trying to debug PHPUnit tests -- is that is what you trying to do?

If not -- please use correct Run/Debug Configuration ("Run | Edit Configurations..." or first entry in that dropdown box on the lft to Run/Debug buttons).

Also -- what PhpStorm version do you use (Help | About) ?

P.S.
Have a look at these articles, in case you have nott seen them yet:

0

Please sign in to leave a comment.