Remove "Can't start GIT" notifications ( PhpStorm)

Hello,

I am using a virtual machine for my development (that has GIT+apache+php installed and properly configured). PhpStorm discovered that GIT is involved, and now it's constantly asking me for the path to the GIT executable, which I can't provide.

I have other notifications that I want to see, and these are clotting the event log, so how can I remove these notifications without satisfying PhpStorms relentless quest for GIT executable?

Thank you,

5 comments

Hi Vlad,

So do you use Git in your project? Do you want to use Git integration in PhpStorm? If yes, then you should set up a correct path to Git executable.

0

Thanks for the reply.

I use GIT, but it's installed on the virtual machine, and I can't access it from PhpStorm. Not using a virtual machine is not an option, since I work on more than 1 project with completely different configurations.

So I don't want to use GIT integration, I just want to completely disable these message.

0

In this case you can disable the Git plugin in Settings | Plugins.

1

Thank you, this is exactly what I was looking for, but completely forgot I had this option

:)
0

Your answer also helped me.thanks~

1

Please sign in to leave a comment.