Cursor placement on mouse click

Something I'm used to with text editors is that when I click to the right of code in whitespace the cursor is positioned at the end of code or "forced" whitespace (either from the tab key or spacebar). Is there a setting I can change so that the cursor is not positioned in no man's land of white space, I looked but I have not been able to find one.

If not a setting, any workarounds? I use a trackball and have little hand dexterity, so the extra effort needed to position the cursor is something I'm trying to avoid.

Two weeks later and I'm still loving PhpStorm :)

2 comments

Hi Mark,

I guess you are after Settings | Editor | Allow placement of caret after end of line

0

Doh! I over looked the general settings pane for the editor; I was focusing on the sub-panes. Unchecked and all is awesome!

Thanks!

0

Please sign in to leave a comment.